Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2004
    Posts
    45

    Unanswered: SQLExpress 2008 Connection Problems / Setup

    I've just setup SQLExpress 2008 on Win 2003 server for the first time. I've attached my databases (from SQL express 2005) and that has worked fine.

    I am trying to now access the data through my web scripts (on same server) and still getting errors like: [Microsoft][ODBC SQL Server Driver][Shared Memory]Invalid connection.

    I'm sure there are just wrong settings for remote access etc. but I want to make sure I have the right ones and not too many things open so it is less secure.

    Here are some of the settings I've made. What am I missing here?

    -SQL server, SQL server reporting service, and sql server browser service are running.
    -Shared Memory and TCP/IP protocols are enabled, named pipes and VIA are disabled.
    -Under TCP/IP properties, all IP addresses are active and enabled, all TCP dynamic ports say "0" and TCP ports say "1433"
    -Under Server Properties, Connections, remote access is enabled.
    -In windows firewall, SQLServer, sqlservr.exe, and sqlbrowser.exe are exceptions.
    -In windows firewall, I've also added port 1433 as an exception.

  2. #2
    Join Date
    Apr 2008
    Location
    Iasi, Romania
    Posts
    561
    Provided Answers: 2
    I think that the "Invalid connection" error message may show some problems with your connection string. Verify how your web server tries to connect to MSSQL.
    Florin Aparaschivei
    DB2 9.7, 10.5 on Windows
    Iasi, Romania

  3. #3
    Join Date
    Jul 2004
    Posts
    45
    Yeah, that seemed to be the problem. My old string was:

    Driver={SQLServer};Server=(local);Database=dbname; Uid=username;Pwd=password;

    That worked fine for 2005 Express. I changed it to:

    Provider=SQLNCLI10;Server=(local);Database=dbname; Uid=username;Pwd=password;

    and it now works. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •