Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2006
    Location
    Tuticorin, India
    Posts
    103

    Unanswered: App Snapshot - Static Commit

    Env: DB2 V8.2/AIX 5.3

    Application snapshot shows around 1000 connections to the database but only around 500 end users are using the application so not sure why 1000 db connection is used for small interval when this problem occurs. It looks more like app issue but I'm trying to help my app team to find the root cause of the pbm. Usually when 500 users are there I see only around 500 connections but sometimes the no of connection spikes to nearly 1000+ for 15 minutes.

    App snap taken when there are 1000+ connection shows that around 800 applications are in "Static Commit Phase". What does this mean ?

    cat snap.app.out | grep "Most recent operation =" | grep "Static Commit" | wc -l
    808

    Pls share your thoughts. Thanks in advance.

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    A wild guess ;-) Are the applications receiving an error message from the db at the point in time when you see more connection than no. of users??? The application may be coded to establish a connection for certian errors - 'unable to connect', 'time out' etc.
    I would start with creating a Connection Event monitor to see when the connections are established, released etc and then compare the times with the application logs ...

    "Most recent operation " in my opinion is not relevant to the problem you are facing ...
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Mar 2006
    Location
    Tuticorin, India
    Posts
    103
    Application is not reporting any error message on WAS log. I do not see any pattern from timing perspective but when I see around 1000+ connection around 75% is of static sql (based on Statement Type from app snapshot).

    Unfortunately since this is prod I cannot use event monitor since we are unable to predict when this problem would occur.

    No error message on db2diag.log either.

    Any thoughts ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •