Results 1 to 5 of 5

Thread: RPC problem

  1. #1
    Join Date
    Mar 2008
    Posts
    96

    Unanswered: RPC problem

    Hi all,
    I am trying to achieve RPC between two ASEs. What I had done to achieve this,till now is

    1. On both the servers i had added the remote servers using sp_addserver
    2. made the entries of the servers in interface files.
    3. created a login on target server and created an external login on source server with same password as on target.

    Now I am able to connect to the remote server using isql ie.
    isql -U<remote_user> -S<Remote_server>

    but when i try to fire a sp from the source server ie
    Remote_server...sp_who

    it gives me the error
    Login to site 'Remote_server' failed.

    Can anyone please guide me which step i had skipped or is there any config parameter need to be changed.

    Thanks in advance

  2. #2
    Join Date
    May 2005
    Location
    South Africa
    Posts
    1,365
    Provided Answers: 1
    I think you have it the wrong way round
    The external login should be on the target server

  3. #3
    Join Date
    Mar 2008
    Posts
    96
    Yes, I tried the reverse also but stillits throwing the same error.

  4. #4
    Join Date
    Jun 2009
    Location
    India
    Posts
    50
    Hi,

    What is the ASE version & which OS platform are u using? Please check configuration parameters for CIS.

    1> sp_helpconfig "cis rpc handling"
    2> go

    cis rpc handling specifies whether Component Integration Services or a site handler is used to send RPCs. The default is 0 (a site handler is used).

    |Minimum Value|Maximum Value|Default Value|Current Value|Memory Used|Unit |Type |
    |-------------|-------------|-------------|-------------|-----------|--------------------|----------|
    | 0| 1| 0| 0| 0|switch |dynamic |

    (return status = 0)
    1> sp_helpconfig "enable cis"
    2> go

    enable cis specifies whether Component Integration Services is loaded when the server is started. The default is 0 (do not load).

    |Minimum Value|Maximum Value|Default Value|Current Value|Memory Used|Unit |Type |
    |-------------|-------------|-------------|-------------|-----------|--------------------|----------|
    | 0| 1| 1| 1| 0|switch |static |

    (return status = 0)

  5. #5
    Join Date
    Mar 2008
    Posts
    96
    Thanks a lot Neevarp. Changing the parameter "cis rpc handling" from 0 to 1 made it work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •