Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2009
    Posts
    8

    Unanswered: message in backup

    Hello
    when I start the local backup
    db2 backup db name_database to /backup

    I got this message:

    SQL2059W A device full warning was encountered on device "/backup".
    Do you want to continue(c), terminate this device only(d), abort the utility(t) ? (c/d/t) c

    I checked the file system and in this file there are this information:

    # ls -l
    total 16777024
    -rw-r----- 1 db2ixp dbixpadm 2147450880 Aug 27 08:30 IXP.0.db2ixp.NODE0000.CATN0000.20090827092807.001
    -rw-r----- 1 db2ixp dbixpadm 2147450880 Aug 27 08:43 IXP.0.db2ixp.NODE0000.CATN0000.20090827092807.002
    -rw-r----- 1 db2ixp dbixpadm 2147450880 Aug 27 08:45 IXP.0.db2ixp.NODE0000.CATN0000.20090827092807.003
    -rw-r----- 1 db2ixp dbixpadm 2147450880 Aug 27 08:46 IXP.0.db2ixp.NODE0000.CATN0000.20090827092807.004


    the size of file system is the 90 Gb
    What 's the reason for this message??
    any suggestion ?



    Regards
    Danny

  2. #2
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Most likely, JFS filesystem is not large enabled so the file can't exceed 2GB

  3. #3
    Join Date
    Aug 2009
    Posts
    8
    But the file for backuping is of 40 GB

    How can I do the backup?? if the size of jsf files are only 2 gb

  4. #4
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Recreate JFS filesystem with the large file enabled option or use JFS2

  5. #5
    Join Date
    Aug 2009
    Posts
    8
    Ok thanks

    Can you please tel me the steps for this opctions that you say me?


    danny

  6. #6
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    bf=true option enables a JFS filesystem for large files. Please see the following URL: Help -


    You'll need to get help from your AIX admin.

  7. #7
    Join Date
    Sep 2003
    Posts
    237
    what does df -g say? You can try backup compress also.
    mota

  8. #8
    Join Date
    Aug 2009
    Posts
    8
    Hello

    this is the result

    # df -g
    /backup (/dev/vg00/backup ) :
    8192 file system block size 1024 fragment size
    102498304 total blocks 102456713 total free blocks
    96053176 allocated free blocks 25614180 total i-nodes
    25614177 total free i-nodes 25614177 allocated free i-nodes
    1073741843 file system id vxfs file system type
    0 flags 255 file system name length
    /backup file system specific string

    I have HP unix 11.23 S.O.

  9. #9
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    I assumed AIX (bad on my part). I don't know if filesystems on HP-UX have any limits. You can try to create a file of 2GB or more to see if you have a similar error. Also, check "ulimit -f" for the instance owner id, default may be 2GB. Talk to your HP-UX admin and ask to set it to ulimited ("file") for the instance owner id, restart the instance and then try the backup again.

  10. #10
    Join Date
    Aug 2009
    Posts
    8
    Hi Bella

    I execute this command
    and this is the result

    # pwd
    /backup
    # ls
    # ulimit -f
    unlimited


    I was speaking with the Hp support I they say me that this problem isn`t for the operating system

    I don`t know, but I will speak with the Hp Unox admin

    thanks Bella

  11. #11
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    From the ls -l output in your original post, all files are close to 2GB so something is preventing DB2 from exceeding this limit. Assuming the filesystem has enough free space, I can think of two things:

    - filesystem limitation
    - user limit (ulimit -f for the instance owner ID)


    ulimit needs to be checked for the instance id. When ulimit is modified, the instance needs to be restarted for the change to be effective. You can try creating a file over 2GB using the dd command to see if you get the same error. Here is an example:

    dd if=/dev/zero of=/home/test/bigfile count=5000000 bs=512

    This command will create a 2.5GB file full of zeros. Example from AIX but should work on HP-UX. If this command fails (when executed using the instance ID), then backup will also fail.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •