Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2009

    Unanswered: Database Corruption? How?

    Database Corruption? How?

    XP MS Works 8.0 ( I don't see exactly where else to post this)

    I use an MS Works 4.0 checkbook DB from W95- have for years. I pasted it into MS Works 8.0 which seems to have absorbed it long ago without flinching and I used it w/o problems from 2005 to 2008. Well here's what happened this year:

    Twice this year I typed in the spent amount and it subtracted it off and got the rong answer. When you type in the spent amount marked 'withdrawn' and 'not cleared' it should subtract it from the checkbook balance but not the bank balance.

    For example yesterday I typed in $18.65 - withdrawn & not cleared.

    What happened was the bank balance went from $3355.00 to $645.59. The Checkbook balance went from $1860.00 also to $645.59 - same thing. Typing further amounts into subsequent records the program worked as it should but based on the $645.59 not the $3350.00.

    There is no $645.59 in my life. No matter WHAT check amount gets typed in the amount field the $645.59 appears as the new bank balance and the new checkbook balance.

    Only way to get around it is to copy the entire input ahead of the bad line to a new template which worked ok.

    What happened? Why? How?

  2. #2
    Join Date
    Feb 2004
    In front of the computer
    Provided Answers: 54
    The answer is really geeky, so let's cut to the chase before we start to explore what broke, why, and how to mitigate the problem...

    The are several solutions that offer ease of use, reasonable cost (some are free), and reliability. I don't know of a solution that offers all three. Working from that list, what are your priorities?

    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  3. #3
    Join Date
    Sep 2009
    Well I did work around it by copying the input data to the blank template I created which is the same template I've been using these past years. Rather an easy workaround.

    I'm really curious just how the corruption may have occurred. It must have ocurred after the template was opened and filled in. That is, the template itself doesn't seem to be corrupted.

    The first time it occurred on line 28; this time on line 238.

    I spose this is really an academic question; but suppose the error was only an easily unseen couple dollars instead of an eye catching $2600 ? And what if it was something more world shaking than a moldy old checking account? Could it have been something I did? or more to the point what kind of happening could cause this?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts