Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2009
    Posts
    39

    Unanswered: Problem wih create index

    I have table proba3 with 60 M records.

    when i want create index, i can't and give error messagge.
    Attached Thumbnails Attached Thumbnails untitled1.JPG  

  2. #2
    Join Date
    Nov 2003
    Posts
    2,933
    Provided Answers: 12
    Try to increase maintenance_work_mem

    http://www.postgresql.org/docs/8.4/static/runtime-config-resource.html#GUC-MAINTENANCE-WORK-MEM

  3. #3
    Join Date
    Sep 2009
    Posts
    39
    Quote Originally Posted by shammat
    I have 6GB of ram memory.

    parameter maintenance_work_mem (integer) is set to 1800M.

    but don't work.

  4. #4
    Join Date
    Nov 2003
    Posts
    2,933
    Provided Answers: 12
    You should post that question to the Postgres mailing list including the operating system version (the one where Postgres runs) and the exact Postgres version

  5. #5
    Join Date
    Sep 2009
    Posts
    39
    solutions of this problem is that parameter maintenance_work_mem (integer) must be set to 256M and work_mem set to 1M.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •