Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2009
    Posts
    3

    Red face Unanswered: MySQL Migration from Windows to Linux Character issue..

    Hello Everyone,

    I am trying to setup a new infrastructure for Apache/PHP/MYSQL, all currently are Windows Server and I am migrating to CentOS in a load balancer enviroment. Everything works however, I am having an annoying problem which I am fighting for few hours now. When I migrate a database over from the Windows server to the Linux Server I am getting bad characters. I have tried character sets and collation on the database but dint help.

    below is an example:

    it's (On the old server)

    It�s (on the new server)

    I have tried mysqldump ----default-character-set=latin1 and then imported the the database but I got the following results.

    The solution i tried was from this link http://www.orthogonalthought.com/blo...al-characters/

    it?s (it changes an apostrophy tp a question mark?)

    I am running out of ideas because I have also tried copying raw files from server tp server and still the same issue.

    Does anyyone what is cusing this character change, i know that defaults backups are UTF8 and i tried changing them using the --default-character-set switch.

    Do i need to change my character set global parameter?

    FYI these are joomla websites, if that makes any difference. Any help is greatly appriciated.

    Thanks,

    Adel

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    sounds like a codepage problem
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    Sep 2009
    Posts
    3
    I am not sure what codepage means, is this a PHP setting that i can specify?

  4. #4
    Join Date
    Sep 2009
    Posts
    3
    I fixed the issue by doing a regular mysqldump --database dbname > dbname.sql

    and then opened the file and changed utf8 to latin1. that fixes the character issue.

    Thanks.

  5. #5
    Join Date
    Jun 2007
    Location
    London
    Posts
    2,527
    Another option is to use the Unix command dos2unix to remove DOS characters.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •