Results 1 to 10 of 10
  1. #1
    Join Date
    Sep 2009
    Posts
    66

    Unanswered: sql1478w for new database

    Hi,

    I can't connect to a brand new database, getting sql1478w - defined buffer pool can't be started. I'm using 9.5 on Linux.

    Thank a lot.

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    You have run out of free memory on the machine. DB2 cannot use virtual memory, real memory must be available.

    You will need to temporarily override your bufferpool sizes, then you can connect into the database and alter bufferpool size(s) via SQL, then reset the override back to null (so the override is no longer in effect).

    These are the steps:

    db2stop
    db2set DB2_OVERRIDE_BPF=1000
    db2start
    db2 connect to <database-name>
    db2 ALTER bufferpool <oversized-bufferpool-name> SIZE <some reasonable number of pages based on real memory available>
    db2 terminate
    db2stop
    db2set DB2_OVERRIDE_BPF=
    db2start
    db2 connect to <database-name>
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Sep 2009
    Posts
    66
    Marcus_A, I did not create any bufferpools. All I did was to issue - create database command.

  4. #4
    Join Date
    Sep 2009
    Posts
    66
    I want to correct myself, I can connect but with sql1478w. I checked the bufferpools - default one exists with a very large size. The size is almost 1.5 gig. I don't understand why it was created using this size if I only have 2 gig of memory on this server.

  5. #5
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Keep in mind that if you receive the SQL1478W error message, the defined buffer pools could not be started. Instead, one very small buffer pool for each page size has been started by DB2. So your database will perform very slowly with such as small bufferpool size when you connect with that error messge. Please change the bufferpool size of the default bufferpool (that you mentioned is defined to 1.5 GB) to something more reasonable and restart DB2.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  6. #6
    Join Date
    Sep 2009
    Posts
    66
    I lowered the buffer pool size and then connected without sql1478w. I then decided to drop the database and created it again - used create database command. Database was created okay and then connect generated sql1478w. I don't understand why.

  7. #7
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Try creating your db with the "autoconfigure apply none" option

  8. #8
    Join Date
    Sep 2009
    Posts
    66
    okay, I dropped the database and created using this option. Connected to the database without sql1478w. Why do I need to use this option?

  9. #9
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Quote Originally Posted by L_DBA_L
    okay, I dropped the database and created using this option. Connected to the database without sql1478w. Why do I need to use this option?
    There is a bug in DB2. I believe it has been fixed in FP4a.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  10. #10
    Join Date
    Jul 2006
    Location
    Pune , India
    Posts
    433
    Quote Originally Posted by Marcus_A
    There is a bug in DB2. I believe it has been fixed in FP4a.
    IBM IZ41200: CONFIGURATION ADVISOR SETTINGS DURING CREATE DB MAY CAUSE CONNECTIONS TO RETURN SQL1489W - United States
    Rahul Singh
    Certified DB2 9 DBA / Application Developer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •