Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2009
    Posts
    5

    Unanswered: Upgrading IBM DB2 from FP12 to FP13 causes loss of data

    Hi,

    I have downloaded DB2 FP13 regular fixpack from the link IBM - DB2 UDB Version 8 FixPaks & client downloads for 32 bit DB2 Products for Linux Operating Systems on 32-bit Intel and AMD systems (x86).
    and I followed all the steps mentioned with the attached document. the link for the document is IBM DB2 Universal Database Version 8.2 FixPak 4 and later (equivalent to Version 8.1 FixPak 11 and later) Readme
    I had fix pack 12 installed on the server before upgrading to FP13 and post upgrade all the data is lost.
    Can anyone has any idea what could be the problem and the possible solution for this?

  2. #2
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,369
    What do you mean by all data is lost? All user tables are empty? Fixpak installation shouldn't touch user data.

  3. #3
    Join Date
    Oct 2009
    Posts
    5

    Upgrading IBM DB2 from FP12 to FP13 causes loss of data

    Hi db2girl, thanks for the reply. Actually i was missing the catalogging step now the data problem is resolved but i am facing some other issue now.
    I have one db2 instance on my portal server and i need to update that too with DB2 FP13 but while updating the instance with the command db2iupdt
    i am getting error as
    opt/IBM/db2/V8.1/instance/db2iupdt: line1 : root/sqllib/bin/db2langdir: No such file or directory
    can you suggest the possible solution for this? Thanks in advance!

  4. #4
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,369
    Did you get a message indicating that db2iupdt complete successfully? If so, are you able to start the instance? Could be related to:
    IBM - IY90430: DB2LANGDIR NOT FOUND ERRORS WHEN EXECUTING INSTANCE COMMANDS, COULD RESULT IN CONNECT ERRORS DUE TO CODEPAGE NOT SET

  5. #5
    Join Date
    Oct 2009
    Posts
    5
    Hi,
    Thanks for the reply.
    I am getting the message as the command run successfully and i am able to start the instance too. but i don't think db2iupdt command is executing properly as i am getting the error msg which i had posted in my last msg. After executing all the steps if i try to add some new entry to database i am getting error as
    create entry failed: [LDAP:error code 80 - Other]. The link which you have given doesn't seem to be related with this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •