Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2007
    Posts
    27

    Unanswered: Loading BLOB data remotely

    Hi all,

    I am facing some problem loading lob data remotely into a database. I am running the following query from my test server where the database is catalogged:

    CONNECT TO MAIN_DB user test using test_pwd;

    Database Connection Information

    Database server = DB2/SUN64 8.2.0
    SQL authorization ID = TEST
    Local database alias = MAIN_DB

    LOAD CLIENT FROM C:\BOSS\scripts\audit_tables\data\BOSS.IOD_IMGDATA _AUDIT.ixf OF IXF LOBS FROM C:\BOSS\scripts\audit_tables\data\lobs\ MODIFIED BY lobsinfile INSERT INTO BOSS.IOD_IMGDATA_audit NONRECOVERABLE

    SQL3025N A parameter specifying a filename or path is not valid.

    Whereas the following query works just fine:

    LOAD CLIENT FROM C:\BOSS\scripts\audit_tables\data\ACTIVITY.MASTER_ AUDIT.ixf OF IXF INSERT INTO ACTIVITY.MASTER_audit NONRECOVERABLE

    SQL3109N The utility is beginning to load data from file

    "C:\BOSS\scripts\audit_tables\data\ACTIVITY.MASTER _AUDIT.ixf".

    Number of rows read = 2
    Number of rows skipped = 0
    Number of rows loaded = 2
    Number of rows rejected = 0
    Number of rows deleted = 0
    Number of rows committed = 2

    I think the lobpath is causing the problem. Any suggestion is greatly appreciated.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    LOB files must reside on the server - this is clearly stated in the manual.
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Sep 2007
    Posts
    27
    Thanks a lot. This worked. Now I have a different problem to cater to (ftp the lob files) and the overhead. Anyways, thanks a lot for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •