Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2007
    Posts
    265

    Unanswered: Problems with restoring database.. help!

    Hi,

    We have an script that runs every night and drops and recreates a database on a server.. I checked today and it doesn't seem like it was able to drop the database, I see this error message in the logs --

    SQL1137W The database manager was unable to remove the database path or some
    of the containers when dropping database "dbase". Cleanup is required.

    I tried to uncatalog, catalog and create the database so I could drop it again but I get this ---

    db2 drop database dbase
    SQL1031N The database directory cannot be found on the indicated file system.
    SQLSTATE=58031


    and because of this when i run the restore, I get this --

    SQL1005N The database alias "dbase" already exists in either the local
    database directory or system database directory. SQLSTATE=00000


    How can I make sure that the database is completely dropped? Thank you!!

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    You will have to manually clean up the path that the DB resided on.

    Andy

  3. #3
    Join Date
    Nov 2007
    Posts
    265
    thank you, i think that worked

  4. #4
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    You don't really need to drop the database prior to restoring it - RESTORE will overwrite the existing database with the same name.
    ---
    "It does not work" is not a valid problem statement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •