Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2009

    Unanswered: informix locale installation

    i have a question about setting locale on informix.

    I'm setting up database which should be in bulgarian, so i set the locale as bg_bg.8859-5 but that locale don't exist in gls, when i try to start the database i always get 'Unable to load locale categories'

    How do I install the bulgarian locale

  2. #2
    Join Date
    Apr 2007
    Jundiai / SP - Brasil
    Hi Wand,

    I don't know the right answer, this is a shoot in the dark...

    The IBM documentation isn't clear how work in this situations...

    I'm curious about this situation and discovery this:

    - In the file $INFORMIXDIR/etc/lc11/registry have a code for Bulgarian:
    /opt/IBM/ids1150uc5de/gls$ find . -exec grep -iH bulgaria {} \;
    ./cm3/registry:MIK              57370   # 0xe01a (commonly used in Bulgaria)
    - Based on this, if you run the glfiles command:
    $ glfiles -cv 
    $ grep -B2 -A1 MIK cv9.txt
    Filenames: cv9/e005e01a.cvo and cv9/e01ae005.cvo
    Between Code Set: unicode
        and Code Set: MIK
    Filenames: cv9/e01ae01c.cvo and cv9/e01ce01a.cvo
    Between Code Set: MIK
        and Code Set: utf8
    Filenames: cv9/e01ae030.cvo and cv9/e030e01a.cvo
    Between Code Set: MIK
        and Code Set: ISO-10646
    Exists a conversion between the MIK (bulgaria) and utf8.
    - The utf8 exists only for English

    My deduce is you need set your DB_LOCALE to en_us.utf8 .
    But my doubt is how set your CLIENT_LOCALE , since don't exists any bg_bg or other *.MIK ...
    My suggestion is try with CLIENT_LOCALE=en_us.utf8 or if just keep unset...
    honestly, I don't believed this will work.. but...

    If you have IBM support, use it....

    Please, if you get a solution, post here...
    César Inacio Martins
    Jundiai / SP - Brasil - em Português - English (translated by Google).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts