Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2009
    Posts
    48

    Unanswered: server parameter file

    my server parameter file is corrupted whenever i issue startup open command it dosnt start by default. Then i have to give the complete path of parameter file.
    i have created server parameter file from parameter but isnt working. how can i get the original one.
    thanxxxxxxxxxxx


    i m getting these errors'
    ORA-01565: error in identifying file 'I:\oracle\product\10.2.0\db_3/dbs/spfileorcl.ora'
    ORA-27046: file size is not a multiple of logical block size
    OSD-04012: file size mismatch
    O/S-Error: (OS 3077) The server is not started.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >i have created server parameter file from parameter but isnt working. how can i get the original one.
    You don't create spfile with any editor.
    You manually make pfile.
    rename spfleorcl.ora initorcl.ora
    & specify it during STARTUP
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    start up the database using pfile and then issue the command as sysdba

    create spfile from pfile;

    which will make a new spfile.

    shutdown immediate;

    startup;

    It will now use the spfile.
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  4. #4
    Join Date
    Aug 2009
    Posts
    262
    I Recommend the same as above
    create spfile=' path ' from pfile='path' .
    shutdown immediate.

    startup.

  5. #5
    Join Date
    Feb 2009
    Posts
    48

    server_parameter file error

    i have done the same way as
    create spile path from pfile path
    but now i m getting these errors whenever i issue startup open command
    ora-24324:service handle not initialized
    ora-01014: internal error.hstdef extension doesn't exist

  6. #6
    Join Date
    Aug 2009
    Posts
    262
    check if you have created from the correct pfile . ( init.ora )

    the location of pfile is some what like ( X:\app\applicatclus\admin\oraedtsystems\pfile )
    search for init.ora in your installation folder and you will get atleast 3 init.ora files . so check

  7. #7
    Join Date
    Aug 2009
    Posts
    262
    give here the contents of your init.ora file ( spfile as well) .

    i will modify it for you .

    also give the contents of your listener.ora , tnsnames.ora and spfile.ora.
    located in NETWORK\admin folder of your installation

  8. #8
    Join Date
    Feb 2009
    Posts
    48
    this is my pfile

    ################################################## ############################
    # Copyright (c) 1991, 2001, 2002 by Oracle Corporation
    ################################################## ############################

    ###########################################
    # Cache and I/O
    ###########################################
    db_block_size=8192
    db_file_multiblock_read_count=16

    ###########################################
    # Cursors and Library Cache
    ###########################################
    open_cursors=300

    ###########################################
    # Database Identification
    ###########################################
    db_domain=""
    db_name=orcl

    ###########################################
    # Diagnostics and Statistics
    ###########################################
    background_dump_dest=I:\oracle\product\10.2.0/admin/orcl/bdump
    core_dump_dest=I:\oracle\product\10.2.0/admin/orcl/cdump
    user_dump_dest=I:\oracle\product\10.2.0/admin/orcl/udump

    ###########################################
    # File Configuration
    ###########################################

    control_files=("I:\oracle\product\10.2.0\oradata\o rcl\control01.ctl",
    "I:\oracle\product\10.2.0\oradata\orcl\control02.c tl",
    "I:\oracle\product\10.2.0\oradata\orcl\control03.c tl")

    db_recovery_file_dest=I:\oracle\product\10.2.0/flash_recovery_area
    db_recovery_file_dest_size=2147483648

    ###########################################
    # Job Queues
    ###########################################
    job_queue_processes=10

    ###########################################
    # Miscellaneous
    ###########################################
    compatible=10.2.0.1.0

    ###########################################
    # Processes and Sessions
    ###########################################
    processes=150

    ###########################################
    # SGA Memory
    ###########################################
    sga_target=289406976

    ###########################################
    # Security and Auditing
    ###########################################
    audit_file_dest=I:\oracle\product\10.2.0/admin/orcl/adump
    remote_login_passwordfile=EXCLUSIVE

    ###########################################
    # Shared Server
    ###########################################
    dispatchers="(PROTOCOL=TCP) (SERVICE=orclXDB)"

    ###########################################
    # Sort, Hash Joins, Bitmap Indexes
    ###########################################
    pga_aggregate_target=96468992

    ###########################################
    # System Managed Undo and Rollback Segments
    ###########################################
    undo_management=AUTO
    undo_tablespace=UNDOTBS1


    THIS IS MY SPFILE


       = ZΓκ) *.SPFILE='I:\oracle\product\10.2.0\db_3/dbs/spfileorcl.ora'

  9. #9
    Join Date
    Aug 2009
    Posts
    262
    i created a test db and ran it with your pfile . it is working fine .
    i went through some digging and consulted few fellows .
    what i come up is this .

    ORA-01041:
    internal error. hostdef extension doesn't exist
    Cause: Pointer to hstdef extension in hstdef is null.
    Action: Report as a bug


    it is on metalink aswell .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •