Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2003
    Provided Answers: 1

    Unanswered: DB2 server does not start, error: ervice terminated with service-specific error 42949

    I have installed DB2 Express-C v9.5 fixpack 2 on Windows XP SP3 and database was working fine for two weeks. Today I have rebooted computer and after Windows restart DB2 service didn't start.

    I went to Control Panel | Services and try to manually start "DB2 - DB2COPY - DB2" service, but got error:
    Windows could not start the DB2 - DB2COPY - DB2 on Local Computer.
     For more information, review the System Event Log. If this is a non-Microsoft
    service, contact te service vendor, and refer to service-specific error
     code -1220."
    I checked Windows Event Log and there is error message:
    The DB2 - DB2COPY1 - DB2 service terminated with service-specific
     error 4294966076 (0xFFFFFB3C).
    For more information, see Help and Support Center at"

    Both of the messages are useless, just some numbers without explanations. What does this error means and how to solve the problem and start DB2 server?
    Last edited by grofaty; 11-25-09 at 07:23.

  2. #2
    Join Date
    Jun 2003
    Toronto, Canada
    Provided Answers: 1
    The database manager shared memory set cannot be allocated.
    The database manager could not allocate its shared memory set. The cause of this error may be insufficient memory resources either for the database manager or the environment in which its operation is being attempted. Memory resources that can cause this error include:

    The number of shared memory identifiers allocated in the system
    The size of the shared memory segment
    The amount of paging or swapping space available in the system
    The amount of physical memory available in the system
    User response:
    One or more of the following:

    Validate that sufficient memory resources are available to satisfy the database manager's requirements, and those of the other programs running on the system.
    On Linux 32-bit, increase the kernel parameter shmmax to 256 MB. On Linux 64-bit, increase the kernel parameter shmmax to 1GB.
    Reduce database manager's memory requirement for this memory set by reducing the database manager configuration parameters which affect it. These are: maxagents, maxdari and, numdb.
    Where appropriate, stop other programs using the system.
    "It does not work" is not a valid problem statement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts