All,
I have recently upgraded db2 UDB from 8.2 to 9.5 on HACMP environment.I have migrated the instance and database on the primary and performed the requested changes on the Secondary node.I have dropped and recreated DAS on primary instead of migrating.I have failed over and started db2 on secondary node and it works great. The only problem is DAS only works on primary and does not start on the secondary node. Below are the details.

OS - AIX 5.3.0.0
db2 - DB2 v9.5.0.4 Fix Pack "4".

PRIMARY NODE:

$ db2 get admin cfg

Admin Server Configuration

Authentication Type DAS (AUTHENTICATION) = SERVER_ENCRYPT

DAS Administration Authority Group Name (DASADM_GROUP) =

DAS Discovery Mode (DISCOVER) = SEARCH
Name of the DB2 Server System (DB2SYSTEM) = <<HOST NAME>>

Java Development Kit Installation Path DAS (JDK_PATH) = AUTOMATIC (/HOME/db2admin/das/java/jdk)
Java Development Kit Installation Path DAS (JDK_64_PATH) = AUTOMATIC (/HOME/db2admin/das/java/jdk)

DAS Code Page (DAS_CODEPAGE) = 0
DAS Territory (DAS_TERRITORY) = 0

Location of Contact List (CONTACT_HOST) =
Execute Expired Tasks (EXEC_EXP_TASK) = NO
Scheduler Mode (SCHED_ENABLE) = OFF
SMTP Server (SMTP_SERVER) =
Tools Catalog Database (TOOLSCAT_DB) =
Tools Catalog Database Instance (TOOLSCAT_INST) =
Tools Catalog Database Schema (TOOLSCAT_SCHEMA) =
Scheduler User ID =

Diagnostic error capture level (DIAGLEVEL) = 3

$ db2admin stop
SQL4407W The DB2 Administration Server was stopped successfully.
$ db2admin start
SQL4406W The DB2 Administration Server was started successfully.

SECONDARY NODE

$ db2 get admin cfg
SQL4404N The DB2 Administration Server does not exist.
$ db2admin start
DB2ADMIN processing complete, SQLCODE = 4404
$ db2admin stop
DB2ADMIN processing complete, SQLCODE = 4404

Thanks in advance..