Results 1 to 3 of 3

Thread: TCP/IP config

  1. #1
    Join Date
    Dec 2009
    Posts
    14

    Unanswered: TCP/IP config

    Hi,

    I install DB2 withot any Instances.
    Than i create an instance.
    Than create a database.
    I can connect via "db2 connect to test".
    Until here all is fine.

    Now i have to use PHP to connect DB2 for usage.
    But it fails evry time.
    In /etc/srvices is no entry.
    Expect: [instanceOwner] TCP/50000
    So I think there is just no TCP/IP connection konfigured.

    Where I can configure it?
    I found no HowTo.
    Any know one?

    Greetings
    Desian

    @ForumAdministrator:
    I want to use Forum Search first. But i mada a mistake with typing. Ok, normaly no Problen i just try agin. And than WHAT? Ihave to wait for 45 sec... ok, i do and try a agin but the 45 sec was counted from my second try that fails cousei have to wait for 45 sec....

    THAT behavior made a user NOT happy!
    45 sec is too slow, if i search anything and Im sure Im not the only one.
    Please cancel that function for an logged in user.
    Please!
    It feels horrible...

  2. #2
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,367
    Update svcename dbm cfg to 5000 using:
    db2 update dbm cfg using svcename 50000


    Also, check that db2comm is set to tcpip using:
    db2set -all


    If not set, set it using:
    db2set db2comm=tcpip


    Restart the instance and try again.

  3. #3
    Join Date
    Dec 2009
    Posts
    14
    Wow!
    You realy know about
    Thx, that solve my problem quickly.

    Greetings
    Desian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •