Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2008
    Posts
    464

    Unanswered: data not visible in table

    Hi guys....9i

    Seeing something strange. In some tables, it seems like data has only been inserted till 31 DEC 09 11:30pm. Although, the EXT table is showing that the latest data (02 JAN 10) is coming in. Checked the tablespace, it's fine. All the logs are showing data is loading fine. But the table itself is showing a max(datetime) of 31/12/09 11:30pm.

    Please advise?

    Regards

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >Please advise?
    you report problems.
    We have no way to verify what you report.
    Enjoy your mystery.
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Aug 2008
    Posts
    464
    Sorry, I'll try to give more detail.

    Not sure how you will verify this. I have a few tables which show data inserted till 31/12/09 11:30pm. But their corresponding EXT tables show data is coming in reguarly, up-to-date. But don't know where it's going from the EXT table as it doesn't look like it's going to the table. I checked the loader logs of the application and they too show that the data is being loaded fine.

    Just wondering if anyone would have any ideas on what could be going on.

  4. #4
    Join Date
    Mar 2007
    Posts
    623
    Ideas? As you did not state what "EXT table" is (extent? external?), the description how load processes and how (meta)data is obtained, I may only tell, there is something wrong in either load and/or data presentation process.

    And, by the way, year has four digits. Are you sure that "31 DEC 09" belongs to this century?

  5. #5
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Quote Originally Posted by shajju
    But don't know where it's going from the EXT table as it doesn't look like it's going to the table
    If you don't know, how are we supposed to know? Perhaps it went to vacation. Perhaps its vehicle had broken while going from EXT table to table. Got the point? It is YOUR system, we have no idea what you do.

    Perhaps it is just a strange system (seen that already) where data that belongs to "year 2009" go to table "input_data", while data that belongs to "2010" go to "new_years_input_data". So, is there any other table that might contain records that are missing in a table you looked at?

    Any log file? How do you know everything went OK last year, if there's no log?

  6. #6
    Join Date
    Aug 2008
    Posts
    464
    Thanks guys.....The problem was that the datetime was not being converted to the correct format i.e., instead of 2010, it was being converted to 1910.

  7. #7
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Oh? And what did Flyboy say?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •