Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2010
    Posts
    3

    Unanswered: SQL through ODBC

    Hi,

    I am running a SQL stored procedure that has been written by someone else for me and if I run it through SQL Query Analyzer is works fine but when I run it through my program via a ODBC it doesn't return a value it just returns the number of rows affected.

    The strange thing is that if I run a stored procedure which doesn't pass any variables it returns the value no problem.

    I have tried running the procedure using ODBCView and I get the same result.

    I know there isn't much info here but just wondered if anyone else had come across this issue.

    Below is the command I use to call the procedure:

    EXEC [RPA].[dbo].[getPdfFilenameNo] '12345', 'jamesisa'

    The procedure does a select and then updates if this helps?

  2. #2
    Join Date
    Apr 2002
    Location
    Toronto, Canada
    Posts
    20,002
    i've asked a moderator to move this thread to the Microsoft SQL Server forum

    this is the Sun MySQL forum
    rudy.ca | @rudydotca
    Buy my SitePoint book: Simply SQL

  3. #3
    Join Date
    Jan 2010
    Posts
    3
    oops sorry. I'll get it moved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •