Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2007
    Posts
    2

    Unanswered: Problem while creating a stored procedure

    Hello,

    I'm facing a tricky problem and i don't know how to fix it ...
    I have installed PSQL 9.50 on my pc ... Under the Database called "DEMOData", i can create stored procedures without any problem ...

    We already installed PSQL 10.0 on our customer server.

    So, now I create a new Database on my machine. And i copied all .ddf and .mkd files on my local machine in order to have the recent and latest version of customer Database.

    Till now evrything works fine. I can open tables, change data structure, do a select querry ...

    But, my only problem is i can't create a very simple stored procedure like this one:

    CREATE PROCEDURE test2();
    Begin

    Select * from colors;

    End ;


    It returns the following error message:

    Save Failed:com.pervasive.psql.utilities.core.DBExcepti on:[LNA][Pervasive][ODBC Engine Interface][Data Record Manager] No such table or object.


    Can anybody tell me how to fix this problem ?


    Thank you for your help ...

    Paul

  2. #2
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Sounds like one of the system tables (PROC.DDF) is missing. Make sure you got all of the DDFs. Also, make sure the DDFs aren't flagged read-only.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Nov 2010
    Posts
    1

    same problem

    I also facing same problem but fixed it already. Thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •