Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2004
    Posts
    3

    Unanswered: Inserting HTML character reference

    Hi,
    am trying to insert an HTML character reference emdash '—' in a varchar2 column. When i try to read the data saved, its been replaced by a '?'. However, it doesn't happen to all the HTML character references since i see the data for '®' correctly. How do i save the data in order to view these special characters without getting substituted by '?'.

    Thanks in advance
    Nim
    Last edited by nirmalakr; 02-03-10 at 21:59.

  2. #2
    Join Date
    Aug 2003
    Location
    Where the Surf Meets the Turf @Del Mar, CA
    Posts
    7,776
    Provided Answers: 1
    >How do i save the data in order to view these special characters without getting substituted by '?'.
    Perhaps you are asking the wrong question.

    One of 2 possible situations exist.
    1) incorrect data is being stored in the DB.
    2) incorrect data is being displayed/presented to the user/viewer.

    SELECT ASCIISTR(field_in_question) from your_table;

    modify line above then using CUT & PASTE post SQL & results back here
    You can lead some folks to knowledge, but you can not make them think.
    The average person thinks he's above average!
    For most folks, they don't know, what they don't know.
    Good judgement comes from experience. Experience comes from bad judgement.

  3. #3
    Join Date
    Feb 2004
    Posts
    3
    It was not an incorrect data. The HTML entity was part of an HTML code that needed to be saved in database. By the way it was not substituting '?' for all HTML entities(eg "&#174" but only for the character reference '&#8212'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •