Results 1 to 11 of 11
  1. #1
    Join Date
    Nov 2009
    Posts
    18

    Unanswered: btrieve error 2301

    i have a error 2301 when i try to connect from oledb to pervasive server.


    what do i wrong?

  2. #2
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    A 2301 is:
    2301: The database name is invalid
    Not a named database. Verify you have entered a valid database name.
    Make sure your connection string is pointing to a correct and valid database name.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Nov 2009
    Posts
    18
    I maked a client database: DATA.

    DATA linked to data source name : DEMODATA.
    this is my source code:

    Code:
                string rdaOleDbConnectString = "Provider=PervasiveOLEDB;"
                                         + @"Data Source=DATA;"
                                         + "Location=SERVER4;"
    i have not a password on the database, but i have error 2301

  4. #4
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Is DATA a Pervasive Database Name or ODBC Data Source Name?
    Just to be clear, DATA is defined on SERVER 4, correct?
    Is this a Web or Windows Application?
    What version of PSQL are you using?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  5. #5
    Join Date
    Nov 2009
    Posts
    18
    it is a odbc data source name.
    DATA are defined on SERVER4
    it is a windows application.
    i use Pervasive sql 8.6 with fixes for oledb (FTF).

  6. #6
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    The "Data Source" parameter needs to be the Database Name not an ODBC DSN. If the DATA ODBC DSN points to the DEMODATA database name, you should use DEMODATA in the connection string.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  7. #7
    Join Date
    Nov 2009
    Posts
    18
    now i have this error: Invalid user authorization

  8. #8
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Is that pointing to DEMODATA or your database? If it's your database, you probably have a Username/Password that needs to be sent on the connection string.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  9. #9
    Join Date
    Nov 2009
    Posts
    18
    now i have this error: An error has occurred on the computer running IIS.


    Code:
    string rdaOleDbConnectString = "Provider=PervasiveOLEDB;"
                                         + @"Data Source=DEMODATA;"
                                         + "Location=SERVER4;"
                                         + "User ID=Master;"
                                         + "Password=test;";

  10. #10
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    I've never seen that error. Is there anything else to the error?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  11. #11
    Join Date
    Mar 2008
    Location
    Netherlands
    Posts
    18
    Quote Originally Posted by tchiloh View Post
    now i have this error: An error has occurred on the computer running IIS.


    Code:
    string rdaOleDbConnectString = "Provider=PervasiveOLEDB;"
                                         + @"Data Source=DEMODATA;"
                                         + "Location=SERVER4;"
                                         + "User ID=Master;"
                                         + "Password=test;";
    Try this one (notice the 'dot'):
    "Provider=PervasiveOLEDB.;"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •