Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2009
    Posts
    16

    Msg 1934, Level 16:INSERT failed because the following SET options have incorrect set

    When I try to Insert record into a temp table by reading XML nodes .I am getting the below mentioned error message.
    Please suggest me what is the problem.

    ANSI_NULLS SET option is currently turned OFF

  2. #2
    Join Date
    Feb 2004
    Location
    One Flump in One Place
    Posts
    14,910
    I don't know about the XML part, but this setting makes the following syntax valid\ invalid:
    Code:
    Value = NULL
    Value <> NULL
    I've never had it turned off and this setting will be effectively deprecated in future editions.
    When you establish a connection there are 7 settings set for that connection - this is one of them. It appears your application is setting this to OFF. Ensure that it is set to on:
    Code:
    SET ANSI_NULLS ON
    Testimonial:
    pootle flump
    ur codings are working excelent.

  3. #3
    Join Date
    Nov 2004
    Location
    on the wrong server
    Posts
    8,545
    Quote Originally Posted by pootle flump View Post
    I don't know about the XML part, but this setting makes the following syntax valid\ invalid:
    the syntax is always valid. it just does not do what you think you want it to do.
    “If one brings so much courage to this world the world has to kill them or break them, so of course it kills them. The world breaks every one and afterward many are strong at the broken places. But those that will not break it kills. It kills the very good and the very gentle and the very brave impartially. If you are none of these you can be sure it will kill you too but there will be no special hurry.” Earnest Hemingway, A Farewell To Arms.

  4. #4
    Join Date
    Feb 2004
    Location
    One Flump in One Place
    Posts
    14,910
    Correct - I didn't know that.
    Testimonial:
    pootle flump
    ur codings are working excelent.

  5. #5
    Join Date
    Oct 2009
    Posts
    16
    I won't get any error message when I Set ANSI_NULLS to ON.The question here is does it affect the database perfomance in anyway when the problem is encountered

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •