Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2010
    Posts
    6

    Unanswered: Database migration rc=2 Problem

    Hi Gurus,
    During the migration of the DB, I am facing the following problem.

    D:\SQLLIB\BIN>Db2 migrate db D73
    SQL1704N Database migration failed. Reason code "2".

    There is one host with 2 db2 instances = 2 database. DB binaries has migrated to 9.5, one of the DB can be migrate, but with the another I am facing this problem.

    Could you help me, what could be the problem?
    DB is not in roll forward pending state.

    Thanks.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Code:
    $ db2 "? sql1704"
    
    
    SQL1704N Database migration failed.  Reason code
              "<reason-code>".
    
    Explanation:
    
    Database migration failed. The reason codes are as follows:
    
    ...
    
     2 database is not migrateable.  The database could be in one of
    the following states:
    
    o   backup pending state
    
    o   roll-forward pending state
    
    o   transaction inconsistent state
    
    o   HADR has marked the database inconsistent
    ---
    "It does not work" is not a valid problem statement.

  3. #3
    Join Date
    Feb 2010
    Posts
    6
    Thanks, I am checking it. None of the above mentioned.
    No hadr in, no backup, and no rollforward pending.
    any other idea?

  4. #4
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Code:
    db2 get db cfg for <yourdb> | findstr "consistent pending"
    ---
    "It does not work" is not a valid problem statement.

  5. #5
    Join Date
    Feb 2010
    Posts
    6
    Thanks, The query did not get back result.
    Maybe it could be an authorisation problem ?
    One host with 2 db. Q73, and D73.
    during the installation of the 9.5, I am using db2q73 user.
    I can migrate the Q73, it is working fine. I can't migrate the D73.
    maybe the problem with the users?
    how could I check it, fix it?
    thanks

  6. #6
    Join Date
    Feb 2010
    Posts
    6
    Thanks, The query did not get back result.
    Maybe it could be an authorisation problem ?
    One host with 2 db. Q73, and D73.
    during the installation of the 9.5, I am using db2q73 user.
    I can migrate the Q73, it is working fine. I can't migrate the D73.
    maybe the problem with the users?
    how could I check it, fix it?
    thanks

  7. #7
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Quote Originally Posted by nemeth81 View Post
    The query did not get back result.
    What query? Can you see the database configuration parameters?
    ---
    "It does not work" is not a valid problem statement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •