Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2008
    Posts
    147

    Unanswered: DB2 monitor switches turn on again

    I've explicitly updated the the Default database monitor switches OFF .
    If I do a db2_kill or db2stop \ db2start - this remains so.

    But if I do a server reboot - the Default database monitor switches turn back on again , I have also set the following and this doe snot change things

    DB2_FMP_COMM_HEAPSZ=0

    How can I permanently turn them off ?
    ---------------------------------
    www.sqlserver-dba.com
    www.dba-db2.com

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Please post the command you used to turn them off, and show the command you used (and the output of that command) to show whether they are still on or off.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Aug 2008
    Posts
    147
    Hi

    Find commands - used , which turns them off - but if I do a server reboot - they are back ON. (except HEALTH_MON ). Just to confirm , that if I do an instance db2stop\db2start - they remain OFF .
    I'm usinng DB2 9.1.0.3 on Linux


    db2set DB2_FMP_COMM_HEAPSZ=0
    db2 update dbm cfg using DFT_MON_BUFPOOL OFF;
    db2 update dbm cfg using DFT_MON_LOCK OFF;
    db2 update dbm cfg using DFT_MON_SORT OFF;
    db2 update dbm cfg using DFT_MON_STMT OFF
    db2 update dbm cfg using DFT_MON_STMT OFF
    db2 update dbm cfg using DFT_MON_TABLE OFF;
    db2 update dbm cfg using DFT_MON_UOW OFF;
    db2 update dbm cfg using HEALTH_MON OFF;
    ---------------------------------
    www.sqlserver-dba.com
    www.dba-db2.com

  4. #4
    Join Date
    Jan 2010
    Posts
    335
    That's really strange! The Commands are okay and it also works with db2stop/db2start.

    Is it a virtual System which might be reset after reboot? (But HEALTH_MON staying off does not fit)

    You should contact IBM Support with that issue.

  5. #5
    Join Date
    Aug 2008
    Location
    Toronto, Canada
    Posts
    2,369
    Do you autostart this instance on reboot? If you're, can you try temporarily disable autostart to see if it makes any difference

  6. #6
    Join Date
    Mar 2010
    Posts
    10
    Hi

    I just had the same issue 2 days ago, rebooting the Linux system brought back the monitoring switches to their initial values (ON)
    I've disabled the IBM Tivoli Storage Manager installed by default with db2, by removing the /etc/rc3.d/S99ITMAgents1 links (the computer is in runlevel 3) and ... it solved the issue. Very strange, but I do no have the time to investigate further on because I don't need the DB2 Tivoli client on the server.

    Stephane

  7. #7
    Join Date
    Mar 2010
    Posts
    10
    ... which is finally no so strange for a monitoring agent to have some monitoring switches turned on.

  8. #8
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Quote Originally Posted by steph66 View Post
    Hi

    I just had the same issue 2 days ago, rebooting the Linux system brought back the monitoring switches to their initial values (ON)
    I've disabled the IBM Tivoli Storage Manager installed by default with db2, by removing the /etc/rc3.d/S99ITMAgents1 links (the computer is in runlevel 3) and ... it solved the issue. Very strange, but I do no have the time to investigate further on because I don't need the DB2 Tivoli client on the server.

    Stephane
    Tivoli System Automation is installed by default (can be used with HADR etc), not Tivoli Storage Manager.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  9. #9
    Join Date
    Mar 2010
    Posts
    10
    Thanks Marcus for your answer.
    Whatever the name is, you are certainly right. The name of the link suggest Ibm Tivoli Monitoring (ITM...) Maybe an odd "cut and paste"
    But I must admit IBM products are really not kiss (keep it stupid and simple) and it took me a lot of time to have db2 to handle correctly 400GB of data under Linux, for a busy transactional internet application (db2 loves as/400)
    Turning these switches off saved about 5 % CPU, based upon the measurments made up to now.

  10. #10
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Quote Originally Posted by steph66 View Post
    Turning these switches off saved about 5 % CPU
    A database server should not be CPU bound. If it is for you, I'm afraid you have bigger problems than monitor switches.

  11. #11
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Quote Originally Posted by steph66 View Post
    Thanks Marcus for your answer.
    Whatever the name is, you are certainly right. The name of the link suggest Ibm Tivoli Monitoring (ITM...) Maybe an odd "cut and paste"
    But I must admit IBM products are really not kiss (keep it stupid and simple) and it took me a lot of time to have db2 to handle correctly 400GB of data under Linux, for a busy transactional internet application (db2 loves as/400)
    Turning these switches off saved about 5 % CPU, based upon the measurments made up to now.
    Actually, I recently installed fixpack 4 for 9.7 and I did notice that IBM Tivoli Monitoring for Databases is now installed in addition to IBM Tivoli System Automation for Multiplatforms (SA MP). I suppose that Tivoli SA uses Tivoli Monitoring for Databases, but not sure.

    I have not noticed that IBM Tivoli Monitoring for Databases is running on our systems, but maybe I have not been looking carefully. Or it may be becasue we don't use Tivoli SA, and in fact the installaton of SA always fails due to some pre-req problem (which we ignore becasue we don't use it--we use Red Hat Cluster Manager instead).
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •