Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2006

    Unanswered: Sacego fails to


    I have a shell script that uses sacego to collect data from an informix database. The problem is that when I run the script manually it works, but when I schedule it from cron it does not work.

    Previously I solved this problem by creating symbolic links to all the libraries in /usr/informix/lib/esql, but now when I apply the same procedure it gives the following error, sacego: fatal: open failed: No such file or directory

    the below listings shows the symbolic links, -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/ -> /usr/informix/lib/esql/

  2. #2
    Join Date
    Dec 2003
    North America
    Chances are you're executing this manually as user "informix" (or your personal userID) but cron is trying to execute it as root. If this is true then the job will fail because the .profile associated with userID "informix" (or your userID) is not being executed and important environment variables are not being set correctly.

    Try adding something to your scheduled cron job to execute the correct .profile first (to set env variables) & see if the problem persists.

    Best of luck with it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts