Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2009
    Posts
    13

    Unanswered: subreport not showing in report footer

    I have a simple report that lists data for many records identified by "Film ID". I'm trying to put a subreport in the report footer (so it will only show once at the end of the report). The subreport is linked to the main form by "Film ID".

    The subreport will not show any records when I put it in the report footer - it will only show the name of the subreport. When I put the subreport in the details section, it does show the correct records for each individual "Film ID". Why won't it list them in the report footer??

  2. #2
    Join Date
    Feb 2004
    Location
    Chicago, IL
    Posts
    1,312
    The reason the data is not showing is because the report is rendered in several steps. First it shows any header records, followed by any detail records and finally the footer is generated. By the time the footer is being generated, all of the detail records have been 'printed', so there are not records for the subreport to link to.

    What kind of data is in the subreport/footer? Does it relate to the detail records? If the data does not relate to the Detail records I believe you can clear the Link Child and Master Fields and it will show the subreport.

  3. #3
    Join Date
    Jul 2009
    Posts
    13
    Well, clearing the links just worked like a charm. I did not know about the steps - thank you for explaining that!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •