Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2010
    Posts
    5

    Unanswered: MySQL does not see databases after upgrade

    Hi,

    I upgrade from 5.0.x to 5.1.45? a few days ago. I installed the upgrade so that that it pointed back to the directories of 5.0, for databases and such.

    I had some trouble with the usernames and pwds but managed to correct that. (I had installed without changing the security settings, or so I thought).

    The problem is that the databases that still are located in the correct directory (Vista C:\....5.0\data) are not "recognized" by the mysql db engine. (It is set up to ISAM - this is a simple set of databases, logging weather data, only one user, me retrieving data).

    Is there a way to attach back the ISAM files to the db engine?

    BTW, I have not run any update checks on the database - cannot find the script directory in the windows version of mysql).

    Thanks in advance for any suggestions to what might have gone wrong and how to reslove the problem!

    IngemarS

  2. #2
    Join Date
    Oct 2003
    Posts
    60
    did you complete the mysql_upgrade from command line?

    http://dev.mysql.com/doc/refman/5.0/...l-upgrade.html

  3. #3
    Join Date
    Apr 2010
    Posts
    5
    Hi Scott,

    Well, no, as I said on the line beginning with BTW, I could not find the script. I tried the mysql_upgrade from the mysql prompts (I tried several of the exe:s in the bin directory, giving my user/pwd credentials but non accepted the mysql_upgrade "command").

    Right now I am away from home so I don't have the details. So, maybe you're on to something - from what exe should the mysql_upgrade be run - believe me, I have checked the 5.1 ref doc, over and over, and it lacks exact info regarding this. However, in a couple of places, on the web, I have read that the Windows installation either does the mysql_upgrade automatically, or isn't needed. There's a lot of mis-information arond and the ref docs are unclear -at least that is my opinion/how I see it.

    I really appreciate any help you can give or clearifying pointers you have.

    Thanks,
    IngemarS

  4. #4
    Join Date
    Apr 2010
    Posts
    5
    Hi again Scott, just a clarification, the scripts directory is empty, no scripts were installed with the 5.1.45 circa 105MB installation. Shouldn't it be there?

    Also the 5.1 ref docs also tells about command prompt and the need for Admin Privs under Vista, so I am aware of that pitfall.

    Thanks again,

    IngemarS

  5. #5
    Join Date
    Apr 2010
    Posts
    5
    Did the mysql_upgrade with this output:
    Looking for 'mysql.exe' as: C:\Program Files\MySQL\MySQL Server 5.0\bin\mysql.exe
    Looking for 'mysqlcheck.exe' as: C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqlcheck.exe
    Running 'mysqlcheck' with connection arguments: "--port=3306"
    Running 'mysqlcheck' with connection arguments: "--port=3306"
    mysql.columns_priv OK
    mysql.db OK
    mysql.event OK
    mysql.func OK
    mysql.general_log
    Error : You can't use locks with log tables.
    status : OK
    mysql.help_category OK
    mysql.help_keyword OK
    mysql.help_relation OK
    mysql.help_topic OK
    mysql.host OK
    mysql.ndb_binlog_index OK
    mysql.plugin OK
    mysql.proc OK
    mysql.procs_priv OK
    mysql.servers OK
    mysql.slow_log
    Error : You can't use locks with log tables.
    status : OK
    mysql.tables_priv OK
    mysql.time_zone OK
    mysql.time_zone_leap_second OK
    mysql.time_zone_name OK
    mysql.time_zone_transition OK
    mysql.time_zone_transition_type OK
    mysql.user OK
    Running 'mysql_fix_privilege_tables'...
    OK
    So everything went ok! But I still do not see my old databases!

    What to do?

    Regards,

    IngemarS

  6. #6
    Join Date
    Apr 2010
    Posts
    5

    Solved!

    Rechecked the my.ini, copied/renamed another .ini and checked the directory options and voila!

    But still don't know why it happened.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •