Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2007
    Posts
    9

    Unanswered: parameterized servername in connection string

    Hi all,
    I have just started to explore the wonders of PostgreSql. and my coding environment is VB.NET
    I am experiencing problem in connection to the database. I need to parameterize the connection string based on the server where the pgsql is installed.
    like constring = "Server=<machine_name_as_parm>;
    other parameter values can work well.
    But if change the server parameter to a different computer name, then it throw an error.
    "Unable to read data from transport connection:"

    Even the hardcoaded ip address also failed.
    my sample con string looks like this..
    strString = String.Format("Host={0};Port={1};User Id={2};Password={3};Database={4};", "172.201.0.39", "5432", "pguser", "pgpwd", "sampledb")

    (My intension is, if in any case the database migrated to a different machine, i can pass the server_machine_name/ip thro login form, and use the same as a parameter to connect to postgres in that machine over network)

    Can anybody help in this regard?

    anticipating helpful responses...

    regards:

  2. #2
    Join Date
    Apr 2010
    Posts
    16
    Following link would be useful for you:
    Postgre SQL Connection String Samples - ConnectionStrings.com

  3. #3
    Join Date
    Jan 2007
    Posts
    9
    Hi Vibhor,
    Thanks for the link.
    I did gone through the connectionstrings.com and as i am using npgsql i have used the exact format for connection string. But when i use <localhost> as the server name connection works well but if i change it to the machine ip address it throws an error.
    Am is missing something or there is other way around.

    hoping to get a resolution for my problem.

  4. #4
    Join Date
    May 2008
    Posts
    277
    Assuming that your script is successfully attempting to connect, then check your listen_addresses setting in postgresql.conf.

  5. #5
    Join Date
    Apr 2010
    Posts
    16
    Futurity is right, please check the listen_address parameter in postgresql.conf. It seems, port is not binded with IP Addess.

  6. #6
    Join Date
    Jan 2007
    Posts
    9
    :Futurity, Vibhor
    Thanks for your information, will definitely go thro the links and come back with some answer..
    thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •