Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2008
    Posts
    13

    Unanswered: copying table contents from another database

    I am attempting to populate a table on one database from another. Here is what I have been trying:

    Code:
    INSERT INTO diag.diag_chart
    SELECT * FROM diag.diag_chart@myPublicLink2Database;
    The chart is under user diag in both schemas. The link keeps giving me an invalid user/password error but it's supposed to be a public link. What am I doing wrong?

  2. #2
    Join Date
    Jan 2004
    Location
    Croatia, Europe
    Posts
    4,094
    Provided Answers: 4
    Who created that database link and how?
    What do you understand the "public" database link is?

  3. #3
    Join Date
    Jun 2004
    Location
    Liverpool, NY USA
    Posts
    2,509
    Where does the database link connect to. The only thing that would cause that error is if the username and password combination didn't exist on the second database
    Bill
    You do not need a parachute to skydive. You only need a parachute to skydive twice.

  4. #4
    Join Date
    Nov 2008
    Posts
    13
    Thanks for the replies. I guess the link was just bad. Here's what I ended up doing:

    Code:
    INSERT INTO diag.diag_chart
    ( SERIES_ID, SGNL_ID, DISP_ORD_NBR )
    
    (select * from diag.diag_chart@updatedLink2Database);

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •