Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2007
    Posts
    265

    Unanswered: Problem removing JAVA UDF

    Hi,

    I'm trying to install a java udf on db2..I tried the command --

    db2 "call SQLJ.INSTALL_JAR('file:/home/db2inst1/java_libs/test-db.jar' , 'testdb')"

    and it worked just fine -- DB20000I The CALL command completed successfully.


    Then, I can also call the function that corresponds the the jar successfully as well --

    db2 "select TESTFUNC(200) from sysibm.sysdummy1"


    However, if I try to remove it by giving the command --

    db2 "call sqlj.remove_jar('testdb')", I get this error

    SQL0444N Routine "*move_jar" (specific name "SQL100420191207610") is
    implemented with code in library or path "...tion/sqlj.remove_jar", function
    "sqlj.remove_jar" which cannot be accessed. Reason code: "4". SQLSTATE=42724


    Any idea how I can fix this? Thanks!
    Last edited by db2user24; 04-20-10 at 17:32.

  2. #2
    Join Date
    Nov 2007
    Posts
    265
    any thoughts on how to solve this? thx!

  3. #3
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Check the message manual for the explanation of SQL0444N.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •