Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2010
    Location
    Boston, MA.
    Posts
    4

    Question Unanswered: Tabbing through subforms....

    Hello all,

    I've been searching through forums trying to find an answer to this question, but I haven't seen anything that addresses this issue....

    I have a form in Access (2003) which has a subform. I have set the tab order of the main form so that the subform is entered second-to-last (the last stop in the tab-order is a button on the main form, to "save and close"). The tab order in the subform is set so that once the last field has been entered the tab jumps back to the "save and close" button on the main form. Here's the issue.... If I continue tabbing through (cycle property is set to "current record"), then on the second cycle the subform is skipped in the tab order -- and in fact I can not even place the cursor in the subform with the mouse. I end up having to close and re-open in order for the form work properly.

    I'm at a loss for what could be causing this. I've tried making the last button refresh the main form. I've tried making a transparent button that directs the next tab back to the sub-form.... I've tried a bunch of things to no avail. I have a feeling that there must be some VB trick, or Macro action that could solve this.... I just haven't found it yet.

    I am a newbie to code and generally know just enough to be dangerous! Any guidance would be most appreciated.

    --Chris

  2. #2
    Join Date
    May 2010
    Posts
    601
    Quote Originally Posted by chayes View Post
    Hello all,

    I've been searching through forums trying to find an answer to this question, but I haven't seen anything that addresses this issue....

    I have a form in Access (2003) which has a subform. I have set the tab order of the main form so that the subform is entered second-to-last (the last stop in the tab-order is a button on the main form, to "save and close"). The tab order in the subform is set so that once the last field has been entered the tab jumps back to the "save and close" button on the main form. Here's the issue.... If I continue tabbing through (cycle property is set to "current record"), then on the second cycle the subform is skipped in the tab order -- and in fact I can not even place the cursor in the subform with the mouse. I end up having to close and re-open in order for the form work properly.

    I'm at a loss for what could be causing this. I've tried making the last button refresh the main form. I've tried making a transparent button that directs the next tab back to the sub-form.... I've tried a bunch of things to no avail. I have a feeling that there must be some VB trick, or Macro action that could solve this.... I just haven't found it yet.

    I am a newbie to code and generally know just enough to be dangerous! Any guidance would be most appreciated.

    --Chris
    Chris,

    Sounds like the sub form is getting the enabled property set to No. This will cause the sub form to not be able to get the focus as you have described.

    Is there any other VBA code in the parent form?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •