Results 1 to 8 of 8
  1. #1
    Join Date
    Jan 2009
    Posts
    14

    Red face Unanswered: Error 11 when using PVTable (PDAC)

    When attempting to use the PvTable component in Delphi 7 we get Btrieve 11 error. This happens on the PDAC samples as well.. The PvQuery components work just fine. The ODBC Express components all work fine.

    Any assistance will be appreciated.

    Thanks.

  2. #2
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    WHat version of PSQL are you using?
    What version of PDAC are you using (version of DRM.DLL)?
    What are you specifying for the PvTable.DatabaseName?
    Does it happen for all tables and all databases?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Jan 2009
    Posts
    14
    PVSQL version: 10.13.037.000

    DRM.DLL version: 10.0.151.0

    Session1.SessionName: PvSession1_1
    Session1.AutoSessionName: True
    Session1.ServerName = Server2

    PvTable1.SessionName: PvSession1_1
    PvTable1DatabaseName: FOSDATA (selected from dropdown)
    PvTable1.TableName: AIRPORTS (selected from dropdown)

    When I set PvTable to Active I get the error message:

    (Btrieve Error 11). Table name is AIRCRAFT. Component is PvTable1, Owned by Form1.

    Thanks.

  4. #4
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Does PDAC work with DEMODATA?

    What is the result if you issue the following in ODBC Test or PCC:
    select * from x$file where xf$name = 'AIRPORTS'
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  5. #5
    Join Date
    Jan 2009
    Posts
    14
    Very interesting results!

    DemoData works fine. And a copy of FOSDATA on my local PC works fine. It appears that the issue is with the database on the server - Server2.

    I did not perform the Select since is works fine on the DemoData database.

    Thanks for the insight. What's next?

  6. #6
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Try the SELECT on your server database (not DEMODATA).
    You might want to check for differences between the server's database and the local copy. Check the Database and Data directories.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  7. #7
    Join Date
    Jan 2009
    Posts
    14
    The query works where ever I run it. The major difference is that on the Server database the locations are different between


    H:\NEWDRIVED\FOSNTDATA\DATA - in the Directory Location field

    and

    \\SERVER2\NEWDRIVED\FOSNTDATA\DATA - in Data Directories

    For DEMOData both are identical.

    Could it be that one uses a UNC path and one doesn't for the database locations?

  8. #8
    Join Date
    Jan 2009
    Posts
    14
    Pardon my fat fingers:

    The first item is the 'Dictionary Location' not 'Directory Location'.

    This information is on the Database Property screen under Directories.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •