Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2004
    Posts
    6

    Unanswered: DB2 Import using a delimited file

    I'm almost done with the script I'm writing to load a DB2 table via a Unix Script. I have one problem which I can't figure out. If I run it from the DB2 console (under Windows), it works, but when I run it via UNIX (my script) on the AIX Server box it doesn't work. I'm using the same generated "del" (delimited) file. I just FTP it from the Unix box to my local device.

    I looked up the error (SQL3035N) and it states I have a Table Name issue. IBM DB2 9.5 Information Center for Linux, UNIX, and Windows

    I just don't understand what the problem is. The tablename is the same in both cases.

    I have shown the "delimited" file I am using. Below are the commands I am using.

    Thanks in advance for you help.

    The contents of my delimited file is as follows,
    "bobg", 1,"2010-06-07 11:45:47.000000",, "eapuser", "2010-06-07 11:45:47.000000", "GE", "<XDS FIL='/data/eapp-db/forms/bobg.xfdl'/>"



    DB2 Console (this works fine):

    import from C:\data\eapuser\data\eapp\delimited_data\TSTPEAP2\ bobg_20100607114547.del of del XML FROM C:\eapp-db\forms\ XMLPARSE PRESERVE WHITESPACE INSERT INTO EAP.FORM;


    Unix Script (this gives an error as shown):

    + db2 import from /data/eapuser/data/eapp/delimited_data/TSTPEAP2/bobg_20100607114547.del of del XML FROM /data/eapp-db/forms/ XMLPARSE PRESERVE WHITESPACE INSERT INTO EAP.FORM;

    SQL3035N The tablename parameter in the target specification is not valid.

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Lose the semicolon or add the -t command line option.

  3. #3
    Join Date
    Apr 2004
    Posts
    6
    Quote Originally Posted by n_i View Post
    Lose the semicolon or add the -t command line option.
    I removed the semicolon and it worked. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •