Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2010
    Location
    Bhilai, Chhattisgarh,India
    Posts
    4

    Unanswered: SQL Server Agent does not start automatically

    Sir,

    Using MSSQL Server 2000.

    My SQL Server Agent does not start automatically even though it is set as to start when OS starts.

    Error log contents are as under :-

    --> Waiting for SQL Server to recover database..
    --> SQL Server:1265 cannot generate SSPI context (SQL STATE HY000)
    --> Unable to connect to server (local); SQL Server Agent cannot start
    --> SQL Server Agent terminated (normally).

    Could you please give me some solution...

    Regards
    Girish Kshire

  2. #2
    Join Date
    Feb 2004
    Location
    In front of the computer
    Posts
    15,579
    Provided Answers: 54
    What version of Windows are you running? It sounds to me like you're running Windows 7 without the Windows XP compatibility installed, and I'm pretty sure that won't work.

    -PatP
    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  3. #3
    Join Date
    Jun 2010
    Location
    Bhilai, Chhattisgarh,India
    Posts
    4
    It is a Windows Server 2003 R2 64 bit OS Service Pack2

  4. #4
    Join Date
    May 2004
    Posts
    7
    See the following
    sql agent cannto start

  5. #5
    Join Date
    Jun 2010
    Location
    Bhilai, Chhattisgarh,India
    Posts
    4
    My problem is not solved yet. Could some one please help me...

  6. #6
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Your problem is that you omit the obvious information, like what account your SQLAgent is configured to run under. Also, has it ever run, or you never saw a single scheduled task executed on its own before?
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  7. #7
    Join Date
    Jun 2010
    Location
    Bhilai, Chhattisgarh,India
    Posts
    4
    Thanks Mr.rdjabarov for taking my problem into consideration to find out solution...
    It has run and executed automatic backup schedule on its own before the problem arose.

    It depends on MSSQL Services.

  8. #8
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    OK then, check the obvious, - service account (disabled, locked, or even if it exists), its password, its SPN registration, if it is in the SQL-designated local groups. And of course, - when was the last time it started successfully, and what happened since, that it started failing.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  9. #9
    Join Date
    Jul 2010
    Posts
    2
    Hi there, go to Administrative Tools> Services
    Then set MS SQL Agent to Automatic.

    Hope that works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •