Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2006
    Posts
    63

    Unanswered: Unable to start SQL Server

    Hi folks,

    Win Server 2008 64 bit
    SQL Server 2008 64 bit


    This is a newly installed SQL Server. During installation I haven't created Server name resulting in unable to start it after installation completed.

    Start -> MS SQL Server 2008 R2 -> SQL Server Management Studio

    Connect so Server
    SQL Server 2008 R2

    Server type: Database Engine
    Server name: ?
    Authentication: SQL Server Authentication
    Login: Administrator
    Password: ******

    Please advise how to add the Server name to start SQL Server? TIA

    B.R.
    satimis

  2. #2
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Try to use your computer name in Server Name combo box.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  3. #3
    Join Date
    Jun 2006
    Posts
    63
    Quote Originally Posted by rdjabarov View Post
    Try to use your computer name in Server Name combo box.
    Hi,


    Thanks for your advice.

    This is my first installation on SQL Server.
    (Version 2008)

    I followed;
    How to Install SQL Server 2008 - A Step by Step Guide - Part 1 and Part 2
    How to Install SQL Server 2008 - A Step by Step Guide

    to proceed.

    Instance ID = MSSQLSERVER
    Login = Administrator

    Cannot connect to SQL Server

    Code:
    Additional information:
    
    A network-related or instance-specific error occurred while 
    establishting a connection to SQL Server.  The server was not found 
    or was not accessible.  Verify that the instace name is correct and
    that SQL Server is configured to allow remote connections. (provider:
    Named Pipes Provider, error: 40 - Could not open a connection to SQL 
    Server)(Microsoft SQL Server, Error: 67)

    Performed following steps;

    On "Sql Server Configuration Manager"
    -> Expand "SQL Server Network Configuration
    -> Protocols for MSSQLSERVER

    Named Pipes Change Disable -> Enable


    Restart SQL Server
    On Command Prompt
    >net stop MSSQLSERVER
    (SQL Server Agent <MSSQLSERVER> stop)

    >net start MSSQLSERVER


    On "Sql Server Configuration Manager"
    -> SQL Server Server

    SQL Server (MSSQLSERVER) Running
    SQL Server Browser Running
    SQL Server Agent (MSSQLSERVER) - stop Running

    Restart "SQL Server Agent"

    Still unable to connect to server, same warning.


    Edit:
    ===

    Finally I made "SQL Server Management Studio" to work with following steps;

    Start -> SQL Server Management Studio

    Connect to Server
    Code:
    Server type: Database Engine
    Server Name: WIN-V24Q6F10HCL
    Athentication: Window Authentication
    (remark: I can't select "SQL Server Authentication" here)
    
    User name:  WIN-V24Q6F10HCL\Administrator (Greyout)
    Password: blank (also greyout)
    -> Connect

    "Microsoft SQL Server Management Studio" starts

    Connect -> SQL Server Agent
    Jobs
    Job Activity Monitor


    But I can't find "New Query" there. Any advice? TIA


    B.R.
    satimis
    Last edited by satimis; 07-03-10 at 23:02.

  4. #4
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    You don't see something like this attached?
    Attached Thumbnails Attached Thumbnails Untitled.png  
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  5. #5
    Join Date
    Jun 2006
    Posts
    63
    Quote Originally Posted by rdjabarov View Post
    You don't see something like this attached?
    Hi rdjabarov,

    Yes, I got it. Clicking it starts "Properties" window. Thanks

    B.R.
    satimis

  6. #6
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    With Windows 2008, you may run into troubles with the local firewall. As a test, shut down the firewall, and try to connect to the server from a different machine. If you can connect, then you need to set a rule for SQL Server traffic on the SQL Server machine. open ports TCP 1433 and UDP 1434.

  7. #7
    Join Date
    Jun 2006
    Posts
    63
    Quote Originally Posted by MCrowley View Post
    With Windows 2008, you may run into troubles with the local firewall. As a test, shut down the firewall, and try to connect to the server from a different machine. If you can connect, then you need to set a rule for SQL Server traffic on the SQL Server machine. open ports TCP 1433 and UDP 1434.
    Hi,

    Thanks for your advice.

    I'm now configuring Win Server 2008 r2. I'll make sure it can be remotely connected by another workstation first. Both Win Server 2008 and SQL server 2008 are newly installed on a VM (guest) of Sun VirtualBox. I'll make use of a Win 7 running on another VM in the same virtual machine to connect the server.

    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •