Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2006
    Posts
    63

    Unanswered: Question on login SQL Server Management Studio

    Hi folks,

    Windows server 2008 R2 Enterprise 64 bit
    SQL server 2008 64 bit

    This is a newly installed box.

    Start -> SQL Server Management Studio

    SQL Server can be login with following settings;

    Server type: Database Engine
    Server name: (local)
    Authentication: Windows Authentication
    User name: WSER2008R202\Administrator (greyout)
    Password: (greyout)

    But I can't login with;
    Authentication: SQL Server Authentication.

    The login name and password taken down during installation can't work.

    On the drop-list of Server namelocal)/(local)/<Browse for more ....>
    Local Servers - Empty
    Network Servers - (... Retrieving data)
    Database Engine
    -> WSER2008R202 (10.50) (highlight it) -> OK

    login: administrator

    Warning:-
    Code:
    TITLE: Connect to Server
    ------------------------------
    Cannot connect to WSER2008R202.
    ------------------------------
    ADDITIONAL INFORMATION:
    
    A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)
    
    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

    On SQL Server Management Studio
    Right click "server" -> Properties -> Connection

    (check) "Allow remote connection to this server"


    Please help. TIA


    B.R.
    satimis

  2. #2
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    Did you enable SQL Standard Security?
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  3. #3
    Join Date
    Jan 2009
    Location
    United Kingdom
    Posts
    77
    Just to doublecheck , check to see the appropriate protocols are enabled via the Configuration Manager- try Named Pipes and TCP\IP

  4. #4
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    If the login attempt is made locally, none of those protocols matter, only Shared Memory.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

  5. #5
    Join Date
    Jun 2006
    Posts
    63
    Hi rdjabarov and Jack,

    Thanks for your advice.

    I sorted out the problem which was caused by entering the wrong login. The correct login is "sa", NOT, Administrator NOR administrator NOR WSER2008R202\Administrator. The password is correct.

    Jack,

    On SQL Server Config Manager
    -> SQL Server Network Config -> Protocols for MSSQLSERVER
    Shared Memory - Enabled
    Named Pipes - Enabled
    TCP/IP - Enabled
    VIA - Disabled


    rdjabarov,

    Where to check "SQL Standard Security"? Thanks


    B.R.
    satimis

  6. #6
    Join Date
    Jul 2003
    Location
    San Antonio, TX
    Posts
    3,662
    in instance properties.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •