Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2010

    Unanswered: log device has become full and database corrupted

    I have a really big problem, help please.
    The database server we use, is ASE 12.5 on win 2003 server. We have a database that contains all our network information and is about 500 MB on a device with the size of 1.5 GB. The database log is on another device (2GB size). Recently the database log became too big and sometimes crashed. I just used to increase the size of the log device and database. Although it worked but I know it was a very bad solution (I should have truncated the database log instead). Yesterday the same problem happened but after resizing I just decided to get a copy of the data and log devices as a backup. So I detached the database, got a copy of the devices and while attaching it back the main problem occurred. The error said that Sybase Central disconnected from ASE and needed to reconnect. It appeared a red (?) mark on the database name. I tried repairing and then dropping but with the error saying that database had not recovered yet ( I think log device is still full). I also noticed that there had been something wrong with backup schedule and I just have the dump file of 2 month ago.
    I shut down the server and format the drive which the database devices were on and run the server again. Now I was able to delete the database. Then I copied the database devices on the same folder they were before and attached database by using the manifest file. Now there is a yellow (!) sign on the database name. When I check the devices I see that there is no database on them. I’ve tried many procedures including the following:
    In the master database, issue the following:

    sp_configure "allow updates to system tables", 1

    1. update sysdatabases
    set status = -32767
    where dbid = id for DB 'x'

    2. checkpoint master database

    3. shutdown and restart ASE Server

    The database should now be in by-pass recovery mode.

    4. use database 'x'

    5. dump tran database with no_log

    6. update sysdatabases set status = 0

    where dbid = ID for db 'x'

    7. checkpoint master

    8. shutdown and restart ASE

    But while trying the “use database” command it said database had not been upgraded yet.
    Help please.
    Thanks in advance for any help

  2. #2
    Join Date
    Nov 2002
    Please view server's errorlog.

  3. #3
    Join Date
    Aug 2010
    the problem has been solved and i'll soon post the solution i tried.
    thanks for your attention hobbylu

  4. #4
    Join Date
    Sep 2008
    What is the solution for the pblm....
    pls share

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts