Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2010
    Posts
    2

    Unanswered: Migrate to 11.50: Stored Procedure won't load.

    Hi All,

    I am in the process of migrating from 7.31 to 11.50 on HP-UX 11.11 PA Arch.

    In the case of this particular instance we are doing this via dbexport / dbimport.

    As part of the dbimport we are experiencing a failure loading 1 particular stored procedure.

    The error we are getting is as follows:

    > dbaccess spg stored_proc.sql

    Database selected.


    312: Cannot update system catalog (sysprocedures).
    Error in line 2
    Near character position 0

    Database closed.

    >

    The error implies that it might be a space issue. We have cleared space & tried again, but still the same.

    We have also installed the rest of the databases stored procs with no problems.

    We have isolated the tables involved, created a test database in the same and another 11.50 instance and the same problem occurs.

    However, when I bring it back to 7.31 it loads with no problems.

    Does anyone have any thoughts.

    All help / suggestions appreciated.

    Regards

    Sean

  2. #2
    Join Date
    Aug 2010
    Posts
    2

    Update

    I have now created a reproducable sql and tested this against ids 11.50 on hpux & solaris and ids 10 on solaris.

    All fail at this point.

    The case has now been escalated to the Labs for resolution.

    Sean

  3. #3
    Join Date
    Sep 2010
    Location
    Germany, Brunswick
    Posts
    55
    Can you post the stored procedure?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •