Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2010
    Posts
    8

    Unanswered: SQL5043N Support for one or more communications protocols failed to start successful

    Hi All,
    I'm trying to configure Portal with DB2. Portal is sitting on a 32-bit Linux machine wherewas DB2 is on a 64-bit Linux machine.

    I could not perform some validate functions from Portal to Db2 due to socket error. After having posted this in Portal forum, experts have redirected me to the Db2 forum for a solution.

    The reason being:

    when I try to su to db2inst1, I get the following error:

    09/09/2010 01:00:09 0 0 SQL5043N Support for one or more communications protocols failed to start successfully. However, core database manager functionality started successfully.
    SQL1063N DB2START processing was successful.


    I doubt this is what is causing the problem (since the communication protocols failed to start). But the core functionality has started though.

    How can I overcome this problem? I'm on DB2 9.1 with Fix Pack 9 on Linux 64-bit box.

    Appreciate if you could shed some light on resolving this issue!!!

    Thank you all in advance..

  2. #2
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Log in as the instance owner (db2inst1) and provide the output of the following commands:

    db2set -all
    db2 get dbm cfg | grep SVCE
    grep -i db2 /etc/services

  3. #3
    Join Date
    Sep 2010
    Posts
    8

    Results of the commands you have given

    Output of db2set -all:
    [db2inst1@amexdb3 ~]$ db2set -all
    [i] DB2_INLIST_TO_NLJN=YES
    [i] DB2_EVALUNCOMMITTED=YES
    [i] DB2_RR_TO_RS=YES
    [i] DB2COMM=tcpip
    [g] DB2SYSTEM=localhost.localdomain
    [g] DB2INSTDEF=db2inst1
    [g] DB2ADMINSERVER=dasusr1


    [db2inst1@amexdb3 ~]$ db2 get dbm cfg | grep SVCE
    TCP/IP Service name (SVCENAME) = DB2COMM

    [db2inst1@amexdb3 ~]$ grep -i db2 /etc/services
    ibm-db2 523/tcp # IBM-DB2
    ibm-db2 523/udp # IBM-DB2
    questdb2-lnchr 5677/tcp # Quest Central DB2 Launchr
    questdb2-lnchr 5677/udp # Quest Central DB2 Launchr
    db2c_db2inst1 50000/tcp
    DB2_db2inst1 60000/tcp
    DB2_db2inst1_1 60001/tcp
    DB2_db2inst1_2 60002/tcp
    DB2_db2inst1_END 60003/tcp


    ****************************************
    I noted something here.. DB2SYSTEM=localhost.localdomain is set to this.. but our hostname is amexdb3.. Do you think this needs to be changed?

    I also have a entry of our host name in the db2nodes.cfg file as well (just to let you know).

    waiting for your advise.. Thanks a lot for the reply..

  4. #4
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Quote Originally Posted by vburra View Post
    [db2inst1@amexdb3 ~]$ db2 get dbm cfg | grep SVCE
    TCP/IP Service name (SVCENAME) = DB2COMM

    [db2inst1@amexdb3 ~]$ grep -i db2 /etc/services
    ibm-db2 523/tcp # IBM-DB2
    ibm-db2 523/udp # IBM-DB2
    questdb2-lnchr 5677/tcp # Quest Central DB2 Launchr
    questdb2-lnchr 5677/udp # Quest Central DB2 Launchr
    db2c_db2inst1 50000/tcp
    DB2_db2inst1 60000/tcp
    DB2_db2inst1_1 60001/tcp
    DB2_db2inst1_2 60002/tcp
    DB2_db2inst1_END 60003/tcp

    SVCENAME must match either the service name or the port listed in /etc/services. This is what tells DB2 on what port to listen for incoming connections. Set the parameter: "update dbm cfg using svcename db2c_db2inst1" and restart the instance.

  5. #5
    Join Date
    Sep 2010
    Posts
    8

    It worked!!!

    Thank you.. It got resolved!!!!

    Thank you very much indeed for assisting me in problem resolution..

    have a nice day!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •