Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2010
    Posts
    3

    Unanswered: DB2 9.1 fp 4 rpm not found in the installtion kit

    Hi All,

    OS: Redhat Enterprise Linux 5
    DB2 v9.1 FP4

    Installation kit /package for DB2 v8.1 FP 12 ships with the various rpm files like IBM_db2cc81-8.1.0-112.i386.rpm, IBM_db2cj81-8.1.0-112.i386.rpm etc. Now I am going to upgrade DB2 for my application to DB2 9.1 FP 4 but I could not find any rpm files in the installation kit for DB2 9.1 FP 4. Anybody knows where I can get DB2 rpm files in the DB2 9.1 FP 4 installation kit, for my application configuration process based on these rpm files.

    I downloaded IBMTivoliDirectoryServerV6.2 and I got DB2 software along with that I got DB2 9.1 FP 4 installation kit.

    Thanks

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    I am not sure I understand what you are trying to do, but you can find DB2 9.1 FP 4 at this site:
    IBM - DB2 Fix Packs by version for DB2 for Linux, UNIX and Windows

    These fixpacks are full cumulative installs so no prior DB2 is needed. Unless you have a very good reason for staying at FP 4 I would recommend FP 9 (assuming you must stay at 9.1). After you install the DB2 code from this site you will be on a 90 Try and Buy License. You can install a permanent 9.1 license anytime after the install.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  3. #3
    Join Date
    Sep 2010
    Posts
    3

    DB2 9.1 fp 4 rpm not found in the installtion kit

    I have DB2 9.1 FP 4 software and already installed, now I am going to install and configure my application (XYZ). In the installation process I have to make a repository that contains all my application related rpms plus DB2 rpms, but I could not found DB2 rpms in the DB2 9.1 FP4installation kit.
    In the DB2 8.1 FP12 all the rpm ships with the installation kit, is IBM change the installation packaging for DB2 9.1 FP 4 and they are not providing rpms along with installation kit.

    I got DB2 9.1 FP4 along with IBMTivoliDirectoryServerV6.2 trail pack
    Last edited by AnuragR; 09-23-10 at 03:31.

  4. #4
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    I don't understand what rpm's you are referring to, nor why you need them to install you application.

    If you need a DB2 client on a remote application server that needs to connect to DB2, then download the appropriate client from the site that I provided above. I am not sure what else an application needs.
    M. A. Feldman
    IBM Certified DBA on DB2 for Linux, UNIX, and Windows
    IBM Certified DBA on DB2 for z/OS and OS/390

  5. #5
    Join Date
    Jan 2010
    Posts
    335
    DB2 does no longer work with RPMs. At least for Version 9.7, but i'm not sure with 9.1. There are various Reasons for it. The Installer or the Fixpacks just remove the old files and extracts a new set from a zipped tar-File.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •