Results 1 to 3 of 3
  1. #1
    Join Date
    Oct 2010
    Location
    New York, NY
    Posts
    3

    Smile Unanswered: 3 categories, list sub-category for 1 (n00b, sorry)

    I'm not a db tech, just self-taught on using CR10.

    I have a report that returns basically:


    CaseID | SourceType | SourceDetail
    CID1 . | Media . . |
    CID2 . | Broker . . | Broker1Name
    CID3 . | Broker . . | Broker2Name
    CID4 . | Friend . . |


    Report works when I just run for Case/SourceType. When I add the SourceDetail field to bring in the broker name that corresponds to each case, the report returns only Broker cases.

    I tried writing a formula (If {cms_Client.SourceID}=2 then {BrokerClientFundings.BrokerFirmName} else '') but of course that didn't work - it still just returned Broker cases.

    I know this is a stupid question -- pretty sure I've even dealt with it before. But right now I just can't figure it out, and I don't even know what search terms to use in order to look it up. Driving me nuts.

    If you need more details, I'd be happy to oblige.

  2. #2
    Join Date
    Oct 2010
    Location
    New York, NY
    Posts
    3

    Would love help with this... Still flummoxed.

    If anyone has insight, I'd appreciate it!!

  3. #3
    Join Date
    Nov 2007
    Posts
    15
    Quote Originally Posted by earthtoned View Post
    I'm not a db tech, just self-taught on using CR10.

    I have a report that returns basically:


    CaseID | SourceType | SourceDetail
    CID1 . | Media . . |
    CID2 . | Broker . . | Broker1Name
    CID3 . | Broker . . | Broker2Name
    CID4 . | Friend . . |


    Report works when I just run for Case/SourceType. When I add the SourceDetail field to bring in the broker name that corresponds to each case, the report returns only Broker cases.

    I tried writing a formula (If {cms_Client.SourceID}=2 then {BrokerClientFundings.BrokerFirmName} else '') but of course that didn't work - it still just returned Broker cases.

    I know this is a stupid question -- pretty sure I've even dealt with it before. But right now I just can't figure it out, and I don't even know what search terms to use in order to look it up. Driving me nuts.

    If you need more details, I'd be happy to oblige.
    its not a crystal problem is a database relationship issue.... did you join the right stuff in the database expert?
    in database expert you can tell the link to do left or right joins. do a left join on your first table. the link should look like this [table1] -> [table2] in database expert

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •