Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2010
    Posts
    10

    Unanswered: having trouble creating full-text catalog

    I'm having trouble setting up full text search on my database. I have been unable to create a fulltext catalog. I get the following message when I try:

    ================================================== ======
    Full-Text Indexing Wizard Progress

    - Create full-text catalog TextCatalog (Error)
    Messages
    * Create full-text catalog failed.

    ------------------------------
    ADDITIONAL INFORMATION:

    Create failed for FullTextCatalog 'TextCatalog'. (Microsoft.SqlServer.Smo)

    For help, click: Source: ID: ( ) - Events And Errors Message Center: Message Details

    ------------------------------

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

    ------------------------------

    Execution of a full-text operation failed. 'Server execution failed' (Microsoft SQL Server, Error: 7689)

    For help, click: Source: MSSQLServer ID: 7689 (SQL Server 09.00.4035) - Events And Errors Message Center: Message Details


    - Create full-text index on eBay_Items.Current_Items (Stopped)

    ================================================== ======

    Also, in management studio when I try to run Management>Full-Text Search>Start I get the message :

    The msftesql service on EMERAC started and then stopped (explorer)


    What can I do about this?

  2. #2
    Join Date
    Nov 2010
    Posts
    10
    Any answers?

  3. #3
    Join Date
    Feb 2010
    Posts
    19
    Just to cover all the bases (at least, the ones I know about):
    * the MSFTESQL service has a valid account (usually same as Server's account)
    * database properties are set to allow full-text searches
    * the database has a unique index column for the key
    * the catalog name is unique for that database
    * you have permission to create the catalog

    Check on those items. If you're still having trouble, drop by again.

  4. #4
    Join Date
    Nov 2010
    Posts
    10
    Thank you for your input. Can you please tell me how to check those things?

    This is my own computer and I installed SQL Server myself, so I should have the permissions, or at least have the authority to grant them to myself, but I don't know what to set.


    The only one of your questions I can answer is this one:

    the catalog name is unique for that database
    Answer: I do not have any existing catalogs. I'm unable to create any. The one I try to create certainly has a unique name.

  5. #5
    Join Date
    Nov 2010
    Posts
    10
    the database has a unique index column for the key
    Actually, I can answer this too. Yes it does.

  6. #6
    Join Date
    Feb 2010
    Posts
    19
    Sorry about the delay, there's been an illness in the family.

    The MSFTESQL service is like any other service in your system. If you're using Windows XP, you should have an Administrative Tools option on the start menu. One of those tools is Services. Open that tool, find MSFTESQL on the list, right-click to pull up its properties, and you'll see a tab for the account/login. If you're using some other OS, the procedure should be similar.

    The account/login for MSFTESQL may match the one for SQL Server itself, in which case it's okay. If it's something different, that may be your problem.

    As for the database properties, you'll need to use this TSQL command:
    SELECT DATABASEPROPERTYEX('<YourDB>'.'IsFullTextEnabled')
    If you get a 1, it's okay. If you get a 0, you'll have to enable that property with this command:
    EXEC [<YourDB>].[dbo].[sp_fulltext_database] @action = 'enable'
    Of course you'll replace <YourDB> with the actual name of your database.

    Permissions get a little tricky. For a stand-alone setup, you could be logged in as the sysadmin.

  7. #7
    Join Date
    Nov 2010
    Posts
    10
    Quote Originally Posted by Shiftmore View Post
    Sorry about the delay, there's been an illness in the family.
    Sorry to hear that. I hope everything is okay now.

    The MSFTESQL service is like any other service in your system. If you're using Windows XP, you should have an Administrative Tools option on the start menu. One of those tools is Services. Open that tool, find MSFTESQL on the list, right-click to pull up its properties, and you'll see a tab for the account/login. If you're using some other OS, the procedure should be similar.

    The account/login for MSFTESQL may match the one for SQL Server itself, in which case it's okay. If it's something different, that may be your problem.
    I don't actually have a service named MSFTESQL.

    I've got one named SQL Server Full Text Search (MSSQLSERVER). Is that the same thing? When I look at the properties for that service it says the name is msftesql .

    This service and the SQL Server both use the local system account.

    As for the database properties, you'll need to use this TSQL command:
    SELECT DATABASEPROPERTYEX('<YourDB>'.'IsFullTextEnabled')
    If you get a 1, it's okay. If you get a 0, you'll have to enable that property with this command:
    EXEC [<YourDB>].[dbo].[sp_fulltext_database] @action = 'enable'
    Of course you'll replace <YourDB> with the actual name of your database.
    Okay, I ran the SELECT command. I got a 1 when I ran it.

    Just to be sure I ran the EXEC command too. It told me command(s) completed successfully.

    However, I still can't start the service.

    Permissions get a little tricky. For a stand-alone setup, you could be logged in as the sysadmin.
    How should I be logged in?

  8. #8
    Join Date
    Feb 2010
    Posts
    19
    Sorry, I'm stumped. It looks like the MSFTESQL service is the problem, but without access to your system it would be hard to diagnose.

    I get a "page not found" error when I click on those error messages. If they work for you, that might be a good place to start.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •