Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789

    Red face Unanswered: connection keeps dropping never happened before

    Hi all I have a question, we have been entering data into a database that has sQL Server 2005 in the background and Access 2007 on the front end for over a year. We connect to it by entering in our user name and password. its not windows authentiction its mixed mode. but for some reason the connection keeps dropping. This happened right after we lost internet (cox cable had an outage) after that we cant seem to stay connected to the database and i dont understand why. SQL Server is on a Server the clients open Access on their pcs then log in with user name and password. they link to sql throught the Data Link Properties of Access 2007I think the odbc connection drops after being idle for a while


    can anyone help please
    I am using Access 2007 to connect via ODBC (SQL Native Client driver) to our
    MSSQL server 2005.
    Nothing wrong with the connection except that it drops after about 8 to 10
    minutes.
    Is there a time out / keep-alive on SQL or ACCESS that needs to be set?
    Thanks.
    Last edited by desireemm; 12-02-10 at 00:41.

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    Are the connections between Access and the SQL Server going over the Cox network? You could try using Netmon to see if Cox is still having problems. Also, you can run profiler on the SQL server to monitor exactly when the disconnect happens (look at the logoff event). Does the 8 - 10 minutes have to be entirely idle? Or can a person be entering data up to the point of failure?

  3. #3
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    Hi MCrowley, yes it is over the cox network. I will run profiler to see when it happens

  4. #4
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    apparently we are not the only ones having this problem, apparently from what I have found out there are other servers with Windows 2003 that are dropping users left and right

  5. #5
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,799
    Provided Answers: 11
    Are there machines that are not running Windows 2003 that have no problems?

  6. #6
    Join Date
    Feb 2004
    Location
    Alpine Califormia
    Posts
    1,789
    Hi MCrowley, just the backup server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •