Results 1 to 11 of 11
  1. #1
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30

    Exclamation Unanswered: Cannot type letters with tilde in the VB editor

    Good day to everyone. I am experiencing an odd thing with the Visual Basic Editor of my MS Access 2003 installation in my home computer. I said odd because whenever I would type any letter with a tilde like , , or only the letter would appear without the tilde like n, e, or a. Even some letters would only appear as symbols like ? or |. However, I can type any letter just fine in a form's text box.

    This oddity does not occur in my work computer.

    Perhaps some of you guys have experienced this before and have found a solution or patch solve the problem. I updated to service pack 3, but the problem is still there.

    I will appreciate your feedback guys. Thanks a lot!
    Attached Thumbnails Attached Thumbnails vbe_screenshot.jpg  
    pao_pao3

  2. #2
    Join Date
    Nov 2004
    Location
    out on a limb
    Posts
    13,692
    Provided Answers: 59
    check your internationalisation settings both for the OS and Microsoft Office
    I'd rather be riding on the Tiger 800 or the Norton

  3. #3
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30
    Hi healdem. I actually checked the Regional settings in Control Panel as well as the Office Language Settings. I added the Spanish language, which mostly has the letters with the tilde. I wonder what's causing this oddity.

    I also installed Visual Studio 2005 and thought maybe there is a conflict with the .NET framework installation. But when I use the IDE of Visual Studio, I can type the letters just fine. It is in the IDE of MS Access that I am having the problems with letters.
    pao_pao3

  4. #4
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30
    Hi guys, I am still unsuccessful in finding a solution to the problem I am encountering in the visual basic environment (VBE). In the coding window, I cannot type , or any letter with a tilde. I already adjusted the Office 2003 language settings to include Spanish, but still no luck. THANKS for any solution guys!
    pao_pao3

  5. #5
    Join Date
    Mar 2009
    Posts
    5,442
    Provided Answers: 14
    Try using ALT 241.
    Have a nice day!

  6. #6
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30

    Exclamation no cigar!

    Hi Sinndho, thanks for your reply. When i type Alt 241, i get the symbol in the code window. I can type all letters fine in any program except in the MS Access 2003 vbe. Weird isn't it!

    I am now checking if any process in task manager is causing conflicts with the vbe. By the way, I just updated to Office 2003 service pack 3 and also Windows XP service pack 3, still no luck.

    Also, I also installed Visual Studio 2005. Does this cause any program conflicts, especially with Office 2003?

    Thanks to any other opinions and solutions guys!
    pao_pao3

  7. #7
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30

    Any suggestions?

    Guys, I am still trying to figure out why I cannot type Spanish letters in the MS Access 2003 VBA Editor.

    When I copy the MDB file I am using to another computer, I can type the Spanish letters just fine.

    Any more suggestions will be appreciated! Thank you!
    pao_pao3

  8. #8
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30

    Thumbs up Solved!

    Guys, I finally have solved the problem! I am now able to type all sorts of special letters (ex: , , , , , ). I followed the guide posted here:

    Unicode - Enabling it fully in Windows XP/2K. Unicode Input in all Windows applications. Unicode Power

    ..to install Unicode support. This guide is very easy to follow, and I hope this will help others with the same problems.
    pao_pao3

  9. #9
    Join Date
    Mar 2009
    Posts
    5,442
    Provided Answers: 14
    Unicode is installed by default on all XP systems I know (250+ machines).
    Have a nice day!

  10. #10
    Join Date
    Jan 2004
    Location
    Philippines
    Posts
    30

    Talking Default unicode support

    Yes, I actually researched on that and XP does have unicode support as a default. But I think somehow my system got screwed up so the guide I posted was of huge help to "repair" the problem
    pao_pao3

  11. #11
    Join Date
    Mar 2009
    Posts
    5,442
    Provided Answers: 14
    Strange really. Anyway, the most important thing is that you were able to solve your problem
    Have a nice day!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •