Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2005
    Posts
    119

    Unanswered: "ODBC error Login Failed…." then "server has not yet been opened "

    Hi, I need your help pls.

    I’m using Crystal Reports ver.7. I’m opening rpt file that was created using ver.7. When I clicked print preview, this error appears:

    ODBC error: [MERANT][ODBC Sybase ASE driver]Login Ffailed, Check for valid user ID, server name and password

    Then the next error appears: Server has not yet been opened

    I’m connecting to the database using ODBC connection. So I tried to convert database driver to pdsodbc.dll [ODBC] and then I selected the datasourcename and input the username, password, etc. It was successful, I was able to connect and see the data. And then I saved the file.

    Now, when I opened the file again, I encountered the same error. The previous settings was restored back. So I had to all the steps above again to see my data. My question is, how will I make the changes permanent w/o going through the same steps again? And did I do the correct steps to view my data?

  2. #2
    Join Date
    Oct 2005
    Posts
    119
    Another simple step I've discovered to see the print preview is to go to menu "Database/Log On Server" then I select the server type. It's working fine, I was able to connect to the DB and see my data. Then I saved the file.

    When I opened the file again, the same problem persist. The server is not automatically logged-on. I need to log-on again to the server. How do I automatically keep it logged-on?

    Thanks.

  3. #3
    Join Date
    May 2009
    Posts
    6
    Is the report running off a different machine? I see that ODBC error most often when the report is being run off another machine (such as a FAT client) versus my machine. If accessed somewhere else, it needs it's own ODBC to connect into the db or you should go into Database/Select Data Source and select the applicable connection method for the report.

    It may not be that at all, but I just thought I'd share my experience.

  4. #4
    Join Date
    Oct 2005
    Posts
    119
    I’m now using crystal ver.11 and the problem did not appear anymore. 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •