Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2009

    Question Unanswered: Login falied for user(null)

    I am getting the following error when I am trying to connect to a remote database via stored proc.

    Login failed for user(null) Not a trusted SQL Connection.

    I am trying to access a remote database.

    I did the following settings on the machine:
    1)I added the server which I am trying to coonect in the Linkedserver using sp_addlinkedserver
    2)I checked the 'Enforced Distriuted transactions' in Connection tab is sqlserver properties.
    3)I am using sql2000 and installed the service pack 4 on tht machine.
    4)I have also set the allow inbound,outbound connections in the Component services in Administrative tools of Control panel.

    Do I need to do something more?

  2. #2
    Join Date
    Feb 2004
    In front of the computer
    Provided Answers: 54

    In theory, theory and practice are identical. In practice, theory and practice are unrelated.

  3. #3
    Join Date
    Jul 2003
    San Antonio, TX
    Did you set up the security settings? Who will be authenticated on the other side and how? Based on the error you're getting your security settings were left at default. You need to:
    1. Either create a standard SQL account on the remote server, and then
    a) map it to the local account
    b) or use it as a login
    2. Or you need to be present as a login on the remote server and a user in the database you're connecting to.
    "The data in a record depends on the Key to the record, the Whole Key, and
    nothing but the Key, so help me Codd."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts