Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2011

    Unanswered: problem about postgresql installation and user login

    hi sir,

    sorry but I'm in trouble eek: as i don't known exactly but postgresql on a system is reset or remove. so when I'm again trying to install postgresql then follow thing happen..

    $ sudo apt-get install postgresql
    [sudo] password for pragmaticvps:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 274kB of archives.
    After this operation, 344kB of additional disk space will be used.
    WARNING: The following packages cannot be authenticated!

    Authentication warning overridden.
    Get:1 lenny/main postgresql 8.3.12-0lenny1 [274kB]
    Fetched 274kB in 0s (4974kB/s)
    Selecting previously deselected package postgresql.
    (Reading database ... 158998 files and directories currently installed.)
    Unpacking postgresql (from .../postgresql_8.3.12-0lenny1_all.deb) ...
    Setting up postgresql (8.3.12-0lenny1) ...
    $ sudo su - postgres
    No directory, logging in with HOME=/

    so when I'm trying to install postgresql then above warning got to me and it install.
    but when I'm trying to login by postgres user then above error it shows.
    I'm new on ubuntu and openerp so please help we.
    please tell me steps to solve above problem..
    Thanking You


  2. #2
    Join Date
    Nov 2006
    WARNING: The following packages cannot be authenticated!
    it is just a warning dont' worry about it. It means that you probably use unstable/testing repos.

    You can try to get rid of that warning and do
    apt-get install debian-archive-keyring
    apt-get update
    it may help.

    No directory, logging in with HOME=/
    You can check the line from /etc/passwd where user postgres is defined.
    At the end of this line is defined user postgres home directory, probably this directory does not exist in the filesystem. You can create it (and make postgres be an owner) or ignore that warning.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts