Results 1 to 12 of 12
  1. #1
    Join Date
    Jan 2011
    Posts
    5

    Unanswered: Aatrix/Timberline Pervasive Error

    Hello. In advance - forgive me for being stupid Windows Server 2003 and all clients have XP Pro. Running Timberline Accounting Software that has a new 3rd party software, Aatrix, to process reports. Aatrix can't connect to the pervasive data base engine. When using the server as a workstation there are no pervasive errors. All workstations have the same error. Pervasive log file shows cache engine failed to communicate with server 3110, 3111 and 3112. Help!!

  2. #2
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    From the Pervasive documentation:
    3110: The network layer is not connected
    The application attempted to use a network connection that was no longer active. This happens when the session with the Pervasive Network Services Layer is still valid, but was dropped by the network. Stop and restart the application.
    3111: Failure during send to the target server
    The Pervasive Network Services Layer attempted to send an application request to the target server and encountered a network specific error from the target. Check the Pervasive Event Log (PVSW.LOG) for more information.
    *Note: If there is a problem with AutoReconnect, a further status code 3131 will be issued.
    3112: Failure during receive from the target server
    The Pervasive Network Services Layer attempted to receive data from the target server and encountered a network specific error. Check the Pervasive Event Log (PVSW.LOG) for more information.
    *Note: If there is a problem with AutoReconnect, a further status code 3131 will be issued.
    You may also receive this error under the following circumstances:
    • When using only the NetBIOS protocol with a remote Workgroup engine, the client is sending more bytes than can fit into the engine’s network read buffer. Go the machine where the remote Workgroup engine is installed, and try increasing the value of the configuration parameter, Server > Communication Buffer Size > Read Buffer Size.
    Is there anything in your PVSW.LOG on the machine with Aatrix?

    Just to confirm, only Aatrix is failing. Is that correct? Does Timberline work correctly from the same machines where Aatrix is running?

    I'm not familiar with Aatrix. Does it use ODBC to connect? If so, have you tried other ODBC applications like Access, Crystal Reports, ODBC Test, or even the Pervasive COntrol Center (even though it uses JDBC since PSQL v9)?
    What version of PSQL are you using?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  3. #3
    Join Date
    Jan 2011
    Posts
    5
    Also receiving status code 3131. There is nothing further in the pvsw.log. There are no errors in the pvsw.log on the server. All machines work correctly with Timberline. The server runs Aatrix with no errors. ODBC is used to connect. Access runs w/o problems.

  4. #4
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    If you're getting a 3131, you should be seeing something in the PVSW.LOG too.

    What version of PSQL are you using?

    To confirm what you are saying, Aatrix runs correctly and connects to the Timberline database when run locally at the server. It only fails when running Aatrix on a client. Is that correct?

    What ODBC driver are you using? Is it the Timberline driver or the PSQL driver? I've seen both installed on systems running Timberline.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  5. #5
    Join Date
    Jan 2011
    Posts
    5
    When I run the pervasive system analyzer, Network Communication is fine, but when I get to Test Transactional Engine the results are 'not able to create btrieve test file due to directory or file name problem'.

  6. #6
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    What ODBC driver are you using? Is it the Timberline driver or the PSQL driver? I've seen both installed on systems running Timberline.

    What version of PSQL are you using?
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  7. #7
    Join Date
    Jan 2011
    Posts
    5
    There are errors on the clients psvw.log, but not on the server. I am using version 10. You are correct. How do I check to see what driver I am running?

  8. #8
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    What are the errors in the client pvsw.log?
    Assuming you are using an ODBC DSN within Aatrix, you should look at the ODBC Administrator, note the driver being used in the DSN, then in the Drivers tab, look at that driver and note the version.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  9. #9
    Join Date
    Jan 2011
    Posts
    5
    The errors in the client pvsw.log are 3110, 3111 and 3112 and 3131. The drivers listed in the ODBC Administrator for pervasive are version 10.30.11.00.

  10. #10
    Join Date
    Dec 2001
    Posts
    1,109
    Provided Answers: 4
    Sounds like there's some network issues going on.
    You might try turning off the Cache engine and see if the errors go away.
    I would also suggest updating to 10.31026 (v10 SP3 Update 10) available at Pervasive PSQL v10.
    Mirtheil Software
    Certified Pervasive Developer
    Certified Pervasive Technician
    Custom Btrieve/VB development
    http://www.mirtheil.com
    I do not answer questions by email. Please post on the forum.

  11. #11
    Join Date
    Mar 2011
    Location
    Noble
    Posts
    1
    Hi everyone, welcome to forum!

  12. #12
    Join Date
    Jul 2011
    Posts
    2
    After updating to Pervasive PSQL v10 most of my problems were solved. The cache engine didn't seem to make much of a difference. It actually was a network issue all along - simply did not have the right updated software.




    __________________
    Clark Ryan
    Marketing Adviser
    SEO Consultant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •