Mysql 5.1.37. Master-slave configuration.

I'm seeing a situation where there are no error messages in the output from "show slave status", no error messages in the <hostname>.err file, and the io_thread and sql_thread on the slave are both running and updating their positions. However, the sql thread does not execute statements in the relay log. It advances the position of the log when new statements arrive, and appears to in fact be working properly, but it simply doesn't execute any test sql statements I might run on the master.

I've tried a whole bunch of different things (rebuilding the database, resetting the slave, granting permissions). In a few cases, it has started working, but then at a later time if I reload the database again in order to sync the master and slave, it will quit working. Ihave tried to identify a sequence of steps it takes to make it work, but without success. It's just not consistent. Sometimes, if I reset the slave it works; while other times it doesn't.

Has anybody experienced something like this?

Is there some kind of debugging for the SQL_THREAD?

Is there a way to tell where SQL_THREAD is in the log (as opposed to where IO_THREAD is)?

Any ideas are appreciated.