Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2008
    Posts
    96

    Unanswered: Stats_time showing old timestamp

    Hi All,

    I am running Db2 9.5 FP 5 on RedHat 5.3. I run runstats once every week and i was looking at the stats_time column in the syscat.tables but the timestamp is from August 2010. Why is the stats_time showing an old timestamp when I am running runstats every week?

    Thanks

  2. #2
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    Are you sure that runstats runs to completion without an error? What is the command you are using for runstats?

    Andy

  3. #3
    Join Date
    Jan 2008
    Posts
    96
    I don't see any error messages in my output file. The command I am using for runstats is:

    runstats on table tableschema.tablename with distribution and indexes all

  4. #4
    Join Date
    Jan 2008
    Posts
    96
    Quote Originally Posted by ARWinner View Post
    Are you sure that runstats runs to completion without an error? Andy
    Actually I did get this warning, not so much an error:

    SQL2314W Some statistics are in an inconsistent state. The newly collected
    "TABLE" statistics are inconsistent with the existing "INDEX" statistics.
    SQLSTATE=01650

  5. #5
    Join Date
    Jan 2008
    Posts
    96
    This system does get a lot of updates so maybe thats why I sometimes see that warning message. But i still don't understand the reason why the stats_time timestamp is way off.

  6. #6
    Join Date
    Jan 2003
    Posts
    4,292
    Provided Answers: 5
    I do not know either. Do all of the tables have the problem, or are some correct?

    Andy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •